WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#29540 closed defect (bug) (invalid)

Single-File Plugins Not Recognized by Add New Screen

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Plugins Keywords:
Focuses: administration Cc:

Description

I often drop single-file plugins into my plugins directories for testing, or for simple convenience. The fancy "Add New" screen in 4.0 doesn't seem to recognize that they are installed, and gives me the "Install Now" button for those plugins.

I know the workaround is to not use the single-file method of installation, but this seems buggy.

Attachments (1)

29540.diff (5.8 KB) - added by mattheu 6 years ago.

Download all attachments as: .zip

Change History (12)

#1 follow-up: @ocean90
6 years ago

I'm confused. How can you see a single-file plugin on the Add New screen? I know that the issue exists on the regular Plugins screen in the details modal for example with Hello Dolly. But that's not new.

#2 follow-up: @nacin
6 years ago

  • Focuses administration added
  • Version changed from 4.0 to 2.8

I don't think this is any change from the plugin installer from 2.8, either. Same underlying code.

#3 in reply to: ↑ 1 ; follow-up: @SergeyBiryukov
6 years ago

Confirmed.

Replying to ocean90:

I'm confused. How can you see a single-file plugin on the Add New screen?

Go to Add Plugins screen, search for Hello Dolly, note the Install Now button.

I know that the issue exists on the regular Plugins screen in the details modal for example with Hello Dolly. But that's not new.

Well, the details modal is new (#17902), but the issue indeed is not, reproduced in 2.8.

#4 in reply to: ↑ 3 @ocean90
6 years ago

Replying to SergeyBiryukov:
Yeah, I know that. I was irritated by "I often drop single-file plugins into my plugins directories".

install_plugin_install_status() seems to be the culprit.

#5 @SergeyBiryukov
6 years ago

The API returns plugin slug (hello-dolly), but not the file name (hello.php).

#6 in reply to: ↑ 2 @miqrogroove
6 years ago

Replying to nacin:

I don't think this is any change from the plugin installer from 2.8, either. Same underlying code.

Ah that's true. Something about the new GUI made it more obvious I guess.

#7 @mattheu
6 years ago

I don't think this is a bug as such...

If you go to the 'add new' plugin screen and add hello dolly, you will end up with 2 copies.

This is a little confusing. But this isn't a bug - its just the way WP identifies plugins. It considers them 2 separate plugins.

However - would it make more sense if the copy of hello dolly bundled with WP was in a directory - so that it would not cause this duplication?

@mattheu
6 years ago

This ticket was mentioned in Slack in #core by sergeybiryukov. View the logs.


6 years ago

#9 @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

#10 @DrewAPicture
5 years ago

  • Resolution changed from worksforme to invalid

#11 @swissspidy
4 years ago

#37351 was marked as a duplicate.

Note: See TracTickets for help on using tickets.