WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 17 months ago

#29559 assigned defect (bug)

Incoming Plugin Updates Not Handled Consistently in Admin Plugin Page

Reported by: dan.rossiter Owned by: swissspidy
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.0
Component: Plugins Keywords: reporter-feedback
Focuses: administration Cc:

Description

When viewing the admin plugin page, I've noticed that sometimes, especially when a plugin was very recently update (eg: I just promoted my own plugin minutes ago then go to update on one of my sites), the message "There is a new version of <plugin name> available." is not displayed. This is *not* due to Core not being aware of the update yet, because the colored left border is red (indicating incoming update).

This has been around for a while (well before 4.0), but I only just now got around to reporting.

Change History (5)

#1 @ocean90
4 years ago

Related/Duplicate: #13071.

#2 @SergeyBiryukov
4 years ago

  • Component changed from Administration to Plugins

#3 follow-up: @DrewAPicture
3 years ago

  • Keywords reporter-feedback added

@danrossiter: Is this still a problem for you?

#4 in reply to: ↑ 3 @dan.rossiter
3 years ago

Replying to DrewAPicture:

@danrossiter: Is this still a problem for you?

Yep.

#5 @swissspidy
17 months ago

  • Owner set to swissspidy
  • Status changed from new to assigned

#13071 was recently fixed. It might have fixed this scenario as well, or fixing it will become easier. Will have a look.

@dan.rossiter It would be awesome if you'd had a screenshot of this. Not sure what you mean with "because the colored left border is red".

Note: See TracTickets for help on using tickets.