WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#29567 closed defect (bug) (worksforme)

Image Upload "Failed to write file to disk"

Reported by: Rene Michaels Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords:
Focuses: Cc:

Description (last modified by ocean90)

When trying to upload a new image in the media library I get an error "Failed to write file to disk" after the WordPress 4.0 update. This appears to be an issue in one particular wordpress as I tested this in other sites I manage and it works fine there.

Are there any new known plugin conflicts with version 4.0?

Change History (3)

#1 @ocean90
4 years ago

  • Description modified (diff)
  • Keywords reporter-feedback added
  • Summary changed from Image Upload "Failed to write to disk" to Image Upload "Failed to write file to disk"

Do you have enough disk space available? Can you upload a file via FTP? Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

The error code UPLOAD_ERR_CANT_WRITE is reported by PHP, see http://de1.php.net/manual/en/features.file-upload.errors.php and tags/4.0/src/wp-admin/includes/file.php#L259

#2 @Rene Michaels
4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the quick response!

OK this is weird, I just logged into my site and I was going to deactivate all my plugins one at a time to see what was causing this. Before doing that, I thought I would go ahead and try the image uploader one more time and this time it worked???

I know this sounds like a neewb issue, but I assure you I have experience with wordpress. I did some troubleshooting yesterday ...deactivated a few plugins I thought may be likely suspects but nothing changed. It was not a disk space issue, I could upload fine via FTP. I do not use the default theme, but it was not a theme issue either. I checked the "upload" directory's file permissions and changed them from 755 to 777 and back again and that didn't seem to do anything.

Since everything worked OK on my other wordpress sites, I assumed there was a plugin in this one that caused this. But it only started after the 4.0 update.

The only thing I can think of is the server cache may have not been completely cleared after deactivating and reactivating some plugins, and this morning it was cleared and all worked.

Anyway, everything seems to be back to normal now.

#3 @SergeyBiryukov
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.