Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#29570 closed feature request (duplicate)

Enable theme-specific configuration files

Reported by: esajuhana's profile esajuhana Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: ui, administration Cc:

Description

When trying a new theme, you always have to edit the theme settings so that the theme won't look completely ridiculous on the previous theme's settings. All themes basically need some kind of customizations to make the theme work somehow. But these settings wont work in another theme. e.g.

Theme 1: Front page: static
Theme 2: Front page: blog
Theme 3: Custom front page

When switching these themes and trying what would be the best, I always end up changing of that front page setting. And that has to be done along every single theme change. It would be a great usability improvement, even if such as the only front page conf file would exist.

Other considerations: Menu conf (what kind of menu works best for this theme), Post conf (summary or full text), Title/logo, tagline, date format...

Most of the conf targets can be extracted from the Settings section and are pretty easily recognizable

Could be implemented like this: "Save these reading settings to currently selected theme" (radios for what should be saved: front page, summary/full text... etc.)

Attachments (1)

General_Settings_‹_Taom_Ti copy.jpg (187.6 KB) - added by esajuhana 10 years ago.

Download all attachments as: .zip

Change History (3)

#1 @SergeyBiryukov
10 years ago

  • Focuses accessibility removed

Related: #27177

#2 @helen
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to call this a duplicate of #19627. The other bits ("save this for current theme") seem very confusing to me, especially given that these are site settings and not a theme setting for a reason.

Note: See TracTickets for help on using tickets.