WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#29584 closed defect (bug) (duplicate)

WordPress post editor <li> <ol> tag issues

Reported by: vamban Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Editor Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

After i updated WordPress 4.0, i am unable to apply <li> and <ol> tags in bulk for my post content instead i have to apply manually for every line.

Also there is black space in post editor visual mode in the top of the editor. And also when i edit media properties, the pencil icon not properly visible when we editing dark coloured image properties. In the earlier version the pencil icon seems good, but not in WordPress 4.0

Change History (11)

#1 follow-up: @SergeyBiryukov
3 years ago

  • Component changed from General to Editor
  • Description modified (diff)
  • Keywords reporter-feedback added
  • Summary changed from Wordpress post editor <li> <ol> tag issues to WordPress post editor <li> <ol> tag issues

Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

#2 in reply to: ↑ 1 @vamban
3 years ago

Replying to SergeyBiryukov:

Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

It happens only after i update wordpress 4.0 version with unchanged plugins list, the same set of plugins are used when i am using v3.9.2. But at that time there is no such issues exist.

#3 @SergeyBiryukov
3 years ago

Could you add screenshots and provide the steps to reproduce these issues on a clean install?

#4 @johnbillion
3 years ago

#29605 was marked as a duplicate.

This ticket was mentioned in IRC in #wordpress-dev by johnbillion. View the logs.


3 years ago

#6 @johnbillion
3 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.0.1

Confirmed. Moving to 4.0.1 for investigation.

#7 follow-up: @johnbillion
3 years ago

To reproduce: Paste this into the visual editor:

one
two
three

Select the lines and then hit the Bulleted List or Numbered List button on the toolbar.

Note that prior to 4.0 this would turn those three lines into three list items. In 4.0 it turns the three lines into one list item with line breaks.

#8 in reply to: ↑ 7 @DrewAPicture
3 years ago

Replying to johnbillion:

To reproduce: Paste this into the visual editor:

one
two
three

Select the lines and then hit the Bulleted List or Numbered List button on the toolbar.

Note that prior to 4.0 this would turn those three lines into three list items. In 4.0 it turns the three lines into one list item with line breaks.

Edit:

There's basically three scenarios in play here:

  1. Writing text in the Visual editor
  2. Writing text in the Text editor
  3. Pasting text in from elsewhere

In my testing, this is what I'm seeing for the ability to bulk-bullet text:

Scenario 3.9.2 4.0.0
Writing text in Visual editor Works Works
Writing text in Text editor (then switching to Visual) Works Doesn't Work
Pasting text in from elsewhere Doesn't work Doesn't work

The "writing text in Text mode, switching to Visual" scenario seems to be reproduceable regression.

Last edited 3 years ago by DrewAPicture (previous) (diff)

#9 @ocean90
3 years ago

Related: #29434

#10 @Kelderic
3 years ago

Tested all three scenarios and confirmed. This is a duplicate of #29434, which was closed last week. The only change in behavior is the 2nd (writing text in Text editor and switching to Visual). +1 for returning to 3.9 behavior.

Use case:

I commonly paste Word or Pages documents into Text Mode to clear formatting and then toggle to Visual to add bullets and headings.

The expected output of wrapping each line individually in list items has changed.

https://core.trac.wordpress.org/ticket/29434#comment:8

#11 @SergeyBiryukov
3 years ago

  • Keywords reporter-feedback needs-patch removed
  • Milestone 4.0.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29434.

Note: See TracTickets for help on using tickets.