WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#29588 closed defect (bug) (worksforme)

Inserting link in editor doesn't switch focus to URL field

Reported by: silentdragoon Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Editor Keywords:
Focuses: Cc:

Description

Before version 4, when you inserted a new link (whether via Ctrl+Alt+A or with the button), the URL field would automatically gain focus, allowing you to quickly type in the URL you wanted and hit enter to add the link.

From version 4, nothing gets focus, so it's not possible to type in the URL without using the mouse to click into the URL field. This makes adding hyperlinks take much longer than necessary.

The same behaviour is exhibited in Visual mode, Distraction Free Writing Mode and Text mode, across three different installations with varying plugins and themes - including one near-stock installation.

Change History (9)

#1 @SergeyBiryukov
6 years ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added

Could not reproduce, the focus is still there.

Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

#2 @silentdragoon
6 years ago

Yes, it still happens with all plugins disabled and a default theme - just checked with a brand new installation of WordPress.

#3 @SergeyBiryukov
6 years ago

Which browser are you using? I tested on Firefox 32 and Chrome 37.

#4 follow-up: @silentdragoon
6 years ago

Chrome 38 64-bit and Firefox 23. The issue doesn't occur in Firefox 32, nor on Chrome 38 64-bit on a colleague's PC. Still an issue using Incognito mode (extensions disabled).

#5 @silentdragoon
6 years ago

  • Keywords reporter-feedback removed

#6 in reply to: ↑ 4 ; follow-up: @iseulde
6 years ago

  • Keywords reporter-feedback added

Replying to silentdragoon:

The issue doesn't occur in Firefox 32, nor on Chrome 38 64-bit on a colleague's PC. Still an issue using Incognito mode (extensions disabled).

You're saying this is only an issue in incognito mode? Which browser? I still cannot reproduce.

#7 in reply to: ↑ description @afercia
6 years ago

Replying to silentdragoon:

Before version 4, when you inserted a new link (whether via Ctrl+Alt+A or with the button)

Please notice the correct keyboard shortcut is Shift+Alt+A.

#8 in reply to: ↑ 6 @silentdragoon
6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to avryl:

Replying to silentdragoon:

The issue doesn't occur in Firefox 32, nor on Chrome 38 64-bit on a colleague's PC. Still an issue using Incognito mode (extensions disabled).

You're saying this is only an issue in incognito mode? Which browser? I still cannot reproduce.

No, both 'normal' and incognito showed the same issue. In an old version of Firefox (23) and Chrome 38 64-bit.

Replying to afercia:

Replying to silentdragoon:

Before version 4, when you inserted a new link (whether via Ctrl+Alt+A or with the button)

Please notice the correct keyboard shortcut is Shift+Alt+A.

Yup, my mistake; I was pressing the correct combination but mis-wrote it here.

In any case, no one else seems to have had this issue and it's gone away from me (as I moved to a new PC), so I'm setting this as 'worksforme'.

#9 @iseulde
6 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

Thanks for the update. :)

Note: See TracTickets for help on using tickets.