WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#29590 closed enhancement (duplicate)

Select image size for gallery in WP media window

Reported by: noplanman Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Gallery Keywords: has-patch needs-testing
Focuses: ui, administration Cc:

Description

It would be great to be able to have a drop down menu to choose the image sizes for galleries. In the same way one can choose the number of columns and where the images link to, being able to select the size makes sense.

I found an easy way to implement this, although I'm not 100% sure that it's the correct place and don't know if the change affects anything else.

I realized, that by adding just the drop down to its place, the setting is automatically applied to the TinyMCE, no extra JS required at all.

Attachments (2)

media-template.php.patch (1.1 KB) - added by noplanman 7 years ago.
gallery-settings-size-selection.png (17.2 KB) - added by noplanman 7 years ago.

Download all attachments as: .zip

Change History (7)

#1 @noplanman
7 years ago

  • Keywords has-patch needs-testing added

#2 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18143.

#3 @SergeyBiryukov
7 years ago

Could you please add your patch to #18143?

#4 @noplanman
7 years ago

Yes of course, I've added it.
Couldn't find that ticket, otherwise I would have added it there to begin with.

#5 @SergeyBiryukov
7 years ago

No problem, thank you for the patch.

Note: See TracTickets for help on using tickets.