WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#29591 closed defect (bug) (wontfix)

Using $wp->request in AJAX does not reflect the correct request

Reported by: ZaneMatthew Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: General Keywords:
Focuses: Cc:

Description (last modified by ocean90)

Should $wp->request be adjusted to return the requested URL for AJAX request or is this the intended behavior?

For example if you are on http://mypage.com/page-a/ and make an AJAX request, then $wp->request is set to '', but it should be set to: 'page-a'.

Change History (4)

#1 @nacin
3 years ago

The WP class is a router, it probably shouldn't act like it knows where an XHR request is coming from.

#2 @ocean90
3 years ago

  • Description modified (diff)

#3 @ZaneMatthew
3 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for the clarification. I've set this to wontfix. The next status change should be closed?

#4 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.