WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29599 closed defect (bug) (duplicate)

Use of WP_Query's nopaging parameter and duplicate content

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Canonical Keywords:
Focuses: Cc:
PR Number:

Description

If I display all posts on a particular page by disabling pagination...

$query = new WP_Query( 'nopaging=true' )

...paged URLs remain 'viewable'. For example, each of the following URLs displays the exact same content:

  • example.com/page-name/page/2/
  • example.com/page-name/page/3/
  • example.com/page-name/page/4/
  • example.com/page-name/page/5/
  • example.com/page-name/page/6/

... and so on.

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28081.

Note: See TracTickets for help on using tickets.