WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#29601 closed defect (bug) (worksforme)

Page/Post Content Editor Scroll Glitch

Reported by: TJR1994 Owned by:
Milestone: Priority: normal
Severity: minor Version: 4.0
Component: Editor Keywords: reporter-feedback
Focuses: ui Cc:

Description (last modified by SergeyBiryukov)

I recently updated a couple of websites I am developing to WordPress 4.0 and I have noticed what appears to possibly be a slight bug with the UI. I have tested the bug in Internet Explorer, Mozilla FireFox and Google Chrome but it only appears to be present in Chrome (and when the zoom is set to 125%).

If the content has around 23 lines (sometimes give or take a few and this includes blank ones) a scroll bar will appear on the right hand side of the content panel. The arrows on the scroll bar will be disabled but if you grab it with your mouse, everything that has been entered into the content panel will become invisible. The content will reappear however, when scrolling using the actual scroll bar for the main page.

After some simple testing, I have only managed to produce the bug under the conditions described above (Google Chrome, 125% Zoom). It's nothing major but perhaps a small UI glitch that could be further investigated?

The content of the post where I first noticed the glitch is as follows:

!!! START OF CONTENT !!!
<p>78 Derngate, Charles Rennie Mackintosh. &nbsp;</p>

<p>In 1917 the Northampton based model maker W.J Bassett-Lowke purchased 78 Derngate, Northampton. A standard 4 terrace property. The forward thinking Bassett-low tracked down the architect Charles Rennie Mackintosh at his Chelsea office to transform the property. They shared a taste for modern non fussy design and together designed 78 Derngate, Basset-Lowke was particularly hands on client. &nbsp;</p>

<p>The result is a stunning and incredibly practical house, with exceptional attention to detail. Influences from Japan, Africa, early signs of Art Deco and European design are all present. The rear of the property was extended 4ft to allow for a terrace and balcony, this floods light into the south facing rear rooms. The master bedroom has french doors and a balcony, inspired by a previous trip by basset-lowke to Europe and the Bathroom has a heated towl rail with Italian marble effect wall paper. Personally the back lit, stair screen wall found in the hall/ lounge and bold decor in the Guest bedroom with its striking white and black stripes alongside, blue silk and squared edged oak furniture really stood out. A must see for any lovers of 20th century interior design. &nbsp;</p>

<p>The restoration of the building is amazing, with original pieces or those now found in museums being replicated, I would recommend the guided tour which was extremely informative, you will need a couple of hours to get the most from your visit. &nbsp;</p>

<p>78 Derngate is open February to Christmas, Tuesday to Sunday, 10am to 5pm. full price admission is £6.20 with concessions available. I would recommend a visit to their dining room restaurant, they serve fabulous afternoon tea!! For further details follow the link below: &nbsp;</p> 

<p><a href="http://www.78derngate.co.uk">http://www.78derngate.org.uk/</a> &nbsp;</p>
!!! END OF CONTENT !!!

Attachments (2)

WordPressGlitch1.jpg (206.1 KB) - added by TJR1994 6 years ago.
WordPressGlitch2.jpg (47.4 KB) - added by TJR1994 6 years ago.
After using the content scroll bar

Download all attachments as: .zip

Change History (6)

@TJR1994
6 years ago

After using the content scroll bar

#1 @TJR1994
6 years ago

  • Severity changed from normal to minor

#2 @SergeyBiryukov
6 years ago

  • Description modified (diff)

#3 @iseulde
6 years ago

  • Keywords reporter-feedback added

I cannot reproduce the issue on a mac + Chrome with zoom 125% and the content you provided (added and removed some line after) in the text editor. Is this still an issue? I've played around with the text editor at other zoom levels and different content and the problem with the scroll bar you describe does not appear.

#4 @afercia
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Tested on two different machines, Windows XP and Windows 10 + Chrome 47 and couldn't reproduce. Also, noticed in the screenshots some non-core buttons ("Media selector" and "Add Template") indicating some active plugins: please consider any bug should be tested disabling all plugins and with a default theme enabled.
No reporter feedback in 12 months, going to close this ticket but feel free to reopen if still relevant.

Note: See TracTickets for help on using tickets.