WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29609 closed defect (bug) (worksforme)

Admin plugin search results are innacurate & inconsistent

Reported by: McGuive7 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Plugins Keywords:
Focuses: ui, administration Cc:

Description (last modified by SergeyBiryukov)

The plugin search results in the WordPress admin don't seem to consistently match the search terms. For example, say I want to install the following plugin: Ambrosite Next/Previous Post Link Plus.

If I search "Ambrosite", I don't get any results ("No plugins match your request.").

If I search "Post Link Plus" I do get results, however Ambrosite Next/Previous Post Link Plus is not included on the first page of results, even though its title has a direct word/order match, and none of the plugins that are displayed do.

If I search "Ambrosite Next/Previous Post Link Plus", the intended plugin finally shows up as the number one result.

It seems to me there are a few issues going on here.

  1. Faulty search matching - why would searching for "Ambrosite" return no results when there is clearly a plugin with that word in the title?
  1. Prioritization - I'm curious what the search matching algorithm is, such that an exact word/order match for the plugin title doesn't yield a top result. This is listed as "fixed" on the following ticket (#8571), however it doesn't seem to be working as described.

Would love to know what the status is on this one, and if this is a known issue. Thanks!

Change History (2)

#1 @nacin
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

https://wordpress.org/plugins/ambrosite-nextprevious-post-link-plus/ hasn't been updated in more than two years, so it is suppressed from search results. A direct match still works. (I kind of like this because if you know exactly what you're looking for, you can find it and it can tell you it's out of date... But it's just an implementation quirk and I don't think it was intended.)

In the future, API-related stuff can be opened at https://meta.trac.wordpress.org/, as this is actually a WordPress.org search. Thanks!

Last edited 5 years ago by nacin (previous) (diff)

#2 @SergeyBiryukov
5 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.