WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29622 closed defect (bug) (duplicate)

WP_Dependencies::recurse_deps infinitely recursion checking handle 'autosave'

Reported by: jeff@… Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Script Loader Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

Not sure why the recursive dependency is present.

In any case, perhaps a check for infinite recursion would be useful since un-related plugins could inadvertently create a mutual dependency that would cause an infinite recursion.

Change History (2)

#1 @wonderboymusic
5 years ago

  • Keywords reporter-feedback added

Thanks for the report, under what circumstances is this happening?

I tried a test case:

add_action( 'admin_footer', function () {
	$woo = wp_script_is( 'autosave' );
	var_dump( $woo );
	exit();
} );

I couldn't reproduce.... could you supply some example code?

#2 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #30518.

Note: See TracTickets for help on using tickets.