WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#29649 closed defect (bug) (duplicate)

JSON in post_content causes Apache to crash

Reported by: ihomefinder Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Formatting Keywords:
Focuses: Cc:

Description

If a post / page contains the below JSON in the post content and then is viewed in a browser, the page will not render and Apache will crash. However, if a node of the JSON is removed, the page will render. If a node is added, the page will not render. This is only occurring on WordPress 4.0.0 with PHP versions 5.2.x - 5.4.x.

If you're using WordPress 3.9.3 or PHP 5.5.x, the issue does not occur.

For testing, I'm using XAMMP 1.8.1 bundle:
-Apache 2.4.3
-MySQL 5.5.27 (Community Server)
-PHP 5.4.7 (VC9 X86 32bit thread safe) + PEAR

[
 {
  "value": "95965",
  "label": "95965",
  "match": "95965",
  "fieldName": "zip",
  "groupLabel": "",
  "uniqueId": "95965"
 },
 {
  "value": "96001",
  "label": "96001",
  "match": "96001",
  "fieldName": "zip",
  "groupLabel": "",
  "uniqueId": "96001"
 },
 {
  "value": "96114",
  "label": "96114",
  "match": "96114",
  "fieldName": "zip",
  "groupLabel": "",
  "uniqueId": "96114"
 }
]

Change History (9)

#1 follow-up: @ocean90
7 years ago

  • Keywords reporter-feedback added

Hello ihomefinder,

can you verify, that this issue is a duplicate of #29557?

#2 in reply to: ↑ 1 @ihomefinder
7 years ago

Hi ocean90,

Yes, it appears to be. Thanks for your help!

Replying to ocean90:

Hello ihomefinder,

can you verify, that this issue is a duplicate of #29557?

#3 @ocean90
7 years ago

  • Component changed from Posts, Post Types to Formatting
  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29557.

Thanks for confirming.

#4 @miqrogroove
7 years ago

The version info and test case should be helpful too. I have a decommissioned 5.4.10 server that I think I can fire up and abuse with various script iterations.

#5 follow-up: @miqrogroove
7 years ago

Still can't get any post-beta test case to crash on 5.4.10.

ihomefinder, did you confirm the patch works for you?

#6 @miqrogroove
7 years ago

PHP Change Log shows PCRE was upgraded at version 5.4.9. I was able to confirm in the PHP Sandbox website that 5.4.9+ appears to be unaffected. What I need now is root access to an older web server to find out exactly what the heck is going on with old PCRE.

#7 in reply to: ↑ 5 ; follow-up: @ihomefinder
7 years ago

Hi miqrogroove,

We're not too familair with checking out and patching WordPress core. I tried checking out the trunk and then applying miqro-29557.5.patch but got a "rejected patch hunks" message from TortoiseSVN.

Is there a guide?

Replying to miqrogroove:

Still can't get any post-beta test case to crash on 5.4.10.

ihomefinder, did you confirm the patch works for you?

#8 in reply to: ↑ 7 @miqrogroove
7 years ago

Replying to ihomefinder:

Is there a guide?

When patching isn't feasible I think upgrading is the official solution. If you want to message me on gmail I could help directly.

#9 @miqrogroove
7 years ago

The updated formatting.php file can be downloaded from https://core.trac.wordpress.org/export/HEAD/trunk/src/wp-includes/formatting.php

That should help until the next version is ready.

Note: See TracTickets for help on using tickets.