WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#29655 closed defect (bug) (duplicate)

Duplicate content when using front-page.php template

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Canonical Keywords:
Focuses: Cc:
PR Number:

Description

Steps to reproduce:

  1. Set "Front page displays" to "A static page"
  2. Set "Front page" to a page you have created via Pages > Add new
  3. Set "Posts page" to a page you created via Pages > Add new
  4. Add a front-page.php template file to your theme
  5. Visit your website's homepage http://example.com

Then try visiting:

http://example.com/page1
http://example.com/page3
http://example.com/page37262
http://example.com/page/1
http://example.com/page/2
http://example.com/page/37262

... etc.

I would have expected a 404 page not found when visiting each of these links but the homepage content is displayed each time.

Change History (4)

#1 @henry.wright
5 years ago

#29587 was marked as a duplicate.

#2 @SergeyBiryukov
5 years ago

  • Component changed from General to Canonical

Related: #11694, #28081.

#3 @SergeyBiryukov
4 years ago

#32685 was marked as a duplicate.

#4 @johnbillion
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28081.

Note: See TracTickets for help on using tickets.