WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29677 closed defect (bug) (duplicate)

Using default permalinks breaks bbPress

Reported by: netweb Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Query Keywords:
Focuses: Cc:
PR Number:

Description

When using the default permalink setting with bbPress 2.5.4 forum hierarchy is broken in WordPress 4.0.

Repro Steps:

  • Install bbPress 2.5.4
  • Check that WordPress permalink settings are set to default
  • Create a bbPress forum e.g. parent
  • Create another bbPress forum with the previous as the parent forum e.g. child

Results:

  • Navigating to https://example.com/?post_type=forum correctly shows the forum list
  • Navigating to https://example.com/?forum=parent works as expected
  • Navigating to https://example.com/?forum=child does not work as expected

Reverting r28803 from #28611 in 4.0 resolves the issue for bbPress but will break the existing fix for #meta523.

Change History (5)

This ticket was mentioned in IRC in #wordpress-dev by netweb. View the logs.


5 years ago

#2 @SergeyBiryukov
5 years ago

  • Milestone changed from Awaiting Review to 4.0.1

#3 @SergeyBiryukov
5 years ago

So, yeah, this is the same issue as in #29615. I was confused by the 3.2.1 reference there.

See comment:8:ticket:29615.

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


5 years ago

#5 @nacin
5 years ago

  • Milestone 4.0.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29615.

Note: See TracTickets for help on using tickets.