WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#29681 closed defect (bug) (duplicate)

Twenty Fourteen: Left Column Drops to the Bottom Way Too Soon

Reported by: Quantumstate Owned by:
Milestone: Priority: normal
Severity: major Version: 4.0
Component: Bundled Theme Keywords: close
Focuses: Cc:

Description

Just as it says. In a regular browser window, I have no left column. It drops all the way to the bottom of the page way too early. I have a regular-sized browser.

I know how the system is supposed to work: Somehow the theme determines the size of the screen currently being used, and parses through the sizes in style.css until it finds one it thinks fits.

But even though my browser window is 1,200 pixels wide, the left column drops dead to the bottom.

Used to be I could fix this by editing style.css and changing
@media screen and (min-width: 1008px) {
... to 500. But with the new WP 4.0 and 2014 1.2, and my child theme, that no longer works. I tried setting that line in my child theme, but realized it has no way of knowing when to invoke that size, so of course it doesn't work.

No one in the user forum, support forum, or IRC knows how the sizing actually takes place, and there is nothing about it anywhere in references on The Internets.

But what do I know is my users don't have any control, as most of them don't parse the many pages to the bottom, to find the panel. It looks like I have only one article to them. https://quantum-sci.com/cacook

So I log this here as a bug. My readers have no control.

Change History (9)

#1 @helen
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

# is not a comment style in CSS, only /* */ is - you've still edited the parent CSS. You are correct in that overriding a CSS media query is not really sanely possible.

Related: #28968

#2 @SergeyBiryukov
6 years ago

  • Component changed from Themes to Bundled Theme
  • Keywords twentyfourteen removed
  • Severity changed from major to normal
  • Summary changed from [Theme twentyfourteen] Left Column Drops to the Bottom Way Too Soon to Twenty Fourteen: Left Column Drops to the Bottom Way Too Soon

#3 @Quantumstate
6 years ago

  • Severity changed from normal to major

Thank you Helen, I've fixed that. But nothing's changed.

I'm sure there's a way to fix this.

Sergey, what do you mean dropping this from major to normal?

My users are effectively denied the whole of my work. None will know to scan all the way to the bottom for the panel.

I've changed it back.

#4 @celloexpressions
6 years ago

  • Resolution changed from worksforme to duplicate
  • Severity changed from major to normal

As helen noted, this is a duplicate of #28968. Please keep in mind that the right (content) sidebar is displayed alongside the content on smaller screen sizes than the left (primary) sidebar, that might fit your needs better.

In a child theme you would need to duplicate all of the logic within that media query and adjust the media query to account for the intermediate sizes, but it is very much possible to override it. But since you edited the theme directly, your change was of course reverted when the theme updated, as all of the update messages warn will happen.

#5 @Quantumstate
6 years ago

  • Resolution duplicate deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened

This problem is not fixed, and it doesn't matter if this is a dupe of the bug I filed before -- nothing is being done about it in either place, and no one even has any suggestions.

Are you not understanding what I'm talking about? Or is this problem intractable? If it can't be solved, just come out and tell me. If the problem is not clear, I can explain it better.

If you're just trying to get rid of me, I am tired of waiting for a solution in the other bug. This is a serious problem, and I suspect is part of the reason this theme has been so massively rejected. I am trying to find a solution.

#6 @knutsp
6 years ago

  • Keywords close added

@Quantumstate: You do not get things done by opening, and reopening, duplicate tickets. Trac is a developers tool and needs one ticket for one thing. Please behave, even if you are frustrated. You are not the only one.

Keep the discussion on the original ticket (#28968), please.

#7 @Quantumstate
6 years ago

Absolutely nothing has been done on that ticket, and it's clear that nothing will be done on this one.

Ditching twenty fourteen as it's busted.

#8 @Kelderic
6 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #28968.

#9 @Quantumstate
6 years ago

Yes, gourd-head and close this problem. I've found a far more advanced solution now.

Note: See TracTickets for help on using tickets.