WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#29702 closed enhancement (duplicate)

Filter for `wp_get_attachment_image_src()`

Reported by: tillkruess Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Media Keywords: has-patch
Focuses: Cc:
PR Number:

Description

I'd love to see a filter for the return value of wp_get_attachment_image_src(), like there is for wp_get_attachment_image(). Is there any reason not to implement that?

Attachments (3)

29702.diff (1.7 KB) - added by MikeHansenMe 5 years ago.
Adds filter and minor code standards improvement
29702.1.diff (1.9 KB) - added by MikeHansenMe 5 years ago.
29702.2.diff (1.6 KB) - added by MikeHansenMe 5 years ago.

Download all attachments as: .zip

Change History (9)

#1 @SergeyBiryukov
5 years ago

  • Component changed from General to Media

@MikeHansenMe
5 years ago

Adds filter and minor code standards improvement

#2 @MikeHansenMe
5 years ago

  • Keywords has-patch added

#3 @johnbillion
5 years ago

  • Version changed from trunk to 2.5

The filter needs more parameters to provide context to make it useful, eg $attachment_id, $size, and $icon.

@MikeHansenMe
5 years ago

#4 @wonderboymusic
5 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from Awaiting Review to Future Release

Patch is exploding

@MikeHansenMe
5 years ago

#5 @MikeHansenMe
5 years ago

  • Keywords has-patch added; needs-patch removed

#6 @swissspidy
4 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32363.

This was fixed in [32866] for 4.3.

Note: See TracTickets for help on using tickets.