WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#29703 closed defect (bug) (duplicate)

Taxonomy Count on Attachments - Not Updating

Reported by: n7studios Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.2
Component: Taxonomy Keywords:
Focuses: Cc:

Description

I've encountered an issue when registered a custom, non-hierarchal taxonomy against attachments / Media Library items.

Creating, editing, deleting tags etc are all working fine and tags are saved against Media Library items.

However, the count of Media items for each tag is always zero.

To reproduce:

  1. Clean install of WordPress 3.9.2 or 4.0
  2. Use register_taxonomy on init action (plugin attached which just does this to demonstrate the issue)
  3. Upload a new image to the Media Library
  4. Add some tags to it
  5. Navigate to Media > Tags; the count beside the tags you have will be zero

I'm not sure if this is something to do with my installation (I don't think so, as I then setup clean installations to double check), or whether registering a taxonomy against an attachment isn't supposed to be possible in WordPress.

Happy to provide more details if needed.

Thanks,

Tim.

Attachments (1)

taxonomy.zip (1.2 KB) - added by n7studios 4 years ago.
Plugin to register a taxonomy against attachments.

Download all attachments as: .zip

Change History (2)

@n7studios
4 years ago

Plugin to register a taxonomy against attachments.

#1 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22558.

Note: See TracTickets for help on using tickets.