WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29720 closed enhancement (maybelater)

tinyMCE editor doesn't allow you to float a gallery left or right

Reported by: RDall Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Gallery Keywords: close
Focuses: ui Cc:
PR Number:

Description

If you add a gallery to WordPress the gallery clears both right and left. The tinyMCE editor doesn't allow you to float a gallery left or right regardless of the size of the gallery. This isn't a problem for 600 width content area and galleries that have 3 columns of photos which is the majority of the themes and the majority of gallery uses.

But if you have a one of two column gallery this leaves a large amount of unused space.

Looking at the Editor layouts for the default themes of twenty fourteen and twenty twelve. You can see in the editor that it takes up the full width of the editable content and if you try aligning left and aligning right nothing will happen.

Twenty Fourteen http://cl.ly/image/1V2o1S010j2c

Twenty Twelve http://cl.ly/image/1w222U1F0q3W

If we have 3 columns of photos this isn't a problem.

But I have two user case scenario's where this might not be best.

If you want to have three images vertically aligned and thumbnailed. You could do this easily if you made a gallery of one column. You could then float this small gallery left or right of the content. This is not currently possible.

The issue is if you were using a wide format content area of a theme. Lets say 800 to 900 pixels wide. (I know we have a 600px as a good width for readability) but say you wanted to float your 2 col or 3 col gallery left of right in a wider screen view. Not currently possible.

If it's possible with the new version of tinyMCE then this would be a great addition to galleries of WordPress.

Change History (6)

#1 @mikeschroder
5 years ago

To me, this seems like a theme decision. Is there something I'm missing here?

This ticket was mentioned in IRC in #wordpress-dev by RDall. View the logs.


5 years ago

#3 @azaozz
5 years ago

  • Component changed from Editor to Gallery
  • Keywords close added

Agree with @DH-Shredder, theme's decision. Also keep in mind that the gallery is actually a shortcode. There's no default attribute in it to set float/alignment. If we add new attribute, all themes will have to implement support for it...

Last edited 5 years ago by azaozz (previous) (diff)

#4 @iseulde
5 years ago

... and currently it is not possible to align views in the editor anyway.

#5 @boonebgorges
5 years ago

  • Version trunk deleted

#6 @helen
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.