WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29737 closed defect (bug) (worksforme)

Insert Media corrupts .jpg files in Firefox, but not IE

Reported by: adiant Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords:
Focuses: administration Cc:

Description

Loading a .jpg in Firefox with Insert Media (Edit Page admin panels) transposes two pieces of the file (see attached files), but files end up with the same byte count. Similar file corruption occurred on other jpg files tested, and the corruption is consistent for a given file, no matter how many times Insert Media is attempted. Very limited testing indicates the issue does not exist with IE.

No error messages are displayed, and the corrupted .jpg file is handled normally by WordPress, with no error messages displayed.

This behaviour has been observed over the last several months with earlier versions of IE and WordPress. And different web hosts.

Current tests (i.e. - the attached files) were done with:
WordPress 4.0
Firefox 32.0.2
IE 10.0.9200.17088
No WordPress Plugins activated
WordPress standard theme (TwentyFourteen) activated
All Firefox extensions and plugins disabled
Windows 8.0 client
Ubuntu 14.04.1 LTS 64-bit (x86_64) server
Apache 2.4.7
PHP 5.5.9
MySQL 5.5.38
WP_DEBUG set to FALSE

Nothing changes when FireBug is activated and WP_DEBUG is set to TRUE. No error messages are displayed. FireBug seems to be indicating that wp-admin/async-upload.php is being executed.

Attachments (3)

Fan.jpg (446.3 KB) - added by adiant 5 years ago.
Original .jpg file
Fan corrupted.jpg (446.3 KB) - added by adiant 5 years ago.
Corrupted file as it appears in wp-content/uploads
Fan browser uploader.jpg (446.3 KB) - added by adiant 5 years ago.
Corrupted file with browser uploader

Download all attachments as: .zip

Change History (8)

@adiant
5 years ago

Original .jpg file

@adiant
5 years ago

Corrupted file as it appears in wp-content/uploads

#1 @azaozz
5 years ago

  • Keywords reporter-feedback added

I think you mean "Uploading a JPEG file with Firefox can corrupt it". Haven't seen any other reports. Can probably be caused by a Firefox addon?

Could you try uploading the same file from the Media => Add New screen, switch to the "browser uploader" there (that means you will be uploading from a simple <input type="file">).

#2 @adiant
5 years ago

Thank you for your comments, especially Media-Add Media, as I was not aware that Media-Add Media and Media Library-Add New were different Admin panels. And I had been looking, unsuccessfully, for the Browser Uploader to test it.

I just tested the Browser Uploader and the media file is also being corrupted, though differently (attached below). Admittedly, since I originally wrote this TRAC ticket, Firefox has updated itself from 32.0.2 to 32.0.3.

As mentioned in the Description, I disabled all Firefox Extensions and Plugins. I just checked the other Add-ins: there are no Services installed and I am using the default Appearance.

I should also mention that further testing shortly after my original report indicated that this problem exists on my two Linux-based hosts (local test Ubuntu server and production ICDSoft web hosting), but it did not exist on an IIS host (test Arvixe Windows web hosting).

@adiant
5 years ago

Corrupted file with browser uploader

#3 @adiant
5 years ago

  • Keywords reporter-feedback removed

#4 @adiant
5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Tests with Firefox 34.0.5 and WordPress 4.1 on the same Ubuntu web server with the same image file no longer corrupts the image.

#5 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.