WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#29762 closed defect (bug) (fixed)

empty <li> element doesn't display normally in TinyMCE

Reported by: zjhzxhz Owned by:
Milestone: 4.1 Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords:
Focuses: ui Cc:

Description

Please do as following steps:

  1. Create a new post
  2. Press some words, such as Reference
  3. Insert a bulleted list, and DO NOT press any thing
  4. Save as draft, and the page will be reloaded
  5. You will find the point of <li> element doesn't display normally

Attachments (1)

TinyMCE-Bug.png (191.3 KB) - added by zjhzxhz 6 years ago.

Download all attachments as: .zip

Change History (5)

@zjhzxhz
6 years ago

#1 in reply to: ↑ description @zjhzxhz
6 years ago

  • Keywords needs-patch added

Replying to zjhzxhz:

Please do as following steps:

  1. Create a new post
  2. Press some words, such as Reference
  3. Insert a bulleted list, and DO NOT press any thing
  4. Save as draft, and the page will be reloaded
  5. You will find the point of <li> element doesn't display normally

the point of <li> element means the point before <li> element.

Sorry for my poor English.

#2 @AugusGils
6 years ago

I am unable to reproduce this on my mac, chrome 37.0.2062.124, Firefox 32.0.3 or Safari 7.1.
Maybe this is a plug-in or theme that adds false css code to your admin backend.

#3 @azaozz
6 years ago

  • Keywords needs-patch removed
  • Milestone changed from Awaiting Review to 4.1

Can't reproduce either however there is some "funkiness" when an UL or OL has only one empty LI. The UL/OL tag is removed after saving but the LI remains. This is fixed in the latest version of TinyMCE (the UL/OL and the LI are removed) and will be fixed in 4.1.

#4 @azaozz
6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Removal of empty UL/OL/LI fixed in [29994]. Feel free to reopen with more info if the LI elements are still not displayed properly.

Note: See TracTickets for help on using tickets.