WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#29791 closed defect (bug) (invalid)

Switching to last page number in plugin search displays no plugins

Reported by: mariusvetrici Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: ui, administration Cc:

Description

Go to Plugins->Add new plugin
In the search box (top right) type in "press". You will get 27 pages.
Go to page 27 (click the >> link)
You will get no plugin on page 27.

The same applies if you go to the last page either by:

Unfortunately this cannot be always reproduced. For other searches I do get results on the last page.

Change History (4)

#1 @DrewAPicture
6 years ago

  • Focuses administration added
  • Keywords needs-patch good-first-bug added
  • Milestone changed from Awaiting Review to 4.1
  • Version changed from trunk to 3.1

Confirmed.

Related: #18724

#2 @dmchale
6 years ago

After doing some testing, I believe this appears to be a bug with the Plugins API itself, not something within Core. I was able to confirm that the same issue exists within the live WordPress repository.

https://wordpress.org/plugins/search.php?page=95&q=press

The website lists 8 per page, and reports 100 pages (which should be correct for 793 results). However, all pages above 95 report "no results found" and you'll note that the final plugins listed on page 95 match the reported issue from page 26 when doing this search from a WordPress installation.

I believe 793 is an incorrect number being returned for some reason, rather than the actual number of results that are publicly visible. If that is the case I don't believe anything can be done to "fix" core, and this will have to be fixed on the systems side of things.

Last edited 6 years ago by dmchale (previous) (diff)

#3 @kovshenin
6 years ago

  • Keywords needs-patch good-first-bug removed
  • Milestone 4.1 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 3.1 deleted

This looks like a bug in our Sphinx + BB_Query hook combo on WordPress.org. Reopening #meta59 for further updates.

#4 @ocean90
6 years ago

#29796 was marked as a duplicate.

Note: See TracTickets for help on using tickets.