WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29799 closed task (blessed) (fixed)

Twenty Fifteen

Reported by: johnbillion Owned by:
Milestone: 4.1 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords:
Focuses: Cc:
PR Number:

Description

This is the reference ticket for the Twenty Fifteen theme which is currently under development, ready for 4.1.

Read the announcement post: https://make.wordpress.org/core/2014/09/09/twenty-fifteen/

https://make.wordpress.org/core/files/2014/09/tf8-1024x796.jpg

Attachments (2)

29799-customize-nomenclature.diff (2.4 KB) - added by studionashvegas 5 years ago.
29799 - Changed all references of "Theme Customizer" to "Customizer"
default-menu.diff (1.1 KB) - added by jeherve 5 years ago.
Display a default menu when no custom menu was created

Download all attachments as: .zip

Change History (27)

#1 @iandstewart
5 years ago

In 29892:

Importing Twenty Fifteen, first pass at our new default theme for 2015, set for 4.1.

It's good for posts, it's good for pages, it might be good for you. Development will occur in trunk. Have at it.

Props matt, iandstewart, iamtakashi, obenland, cainm, kristastevens, karmatosed, chellycat, lancewillett, kwight, davidakennedy. See #29799

#2 @nacin
5 years ago

In 29893:

Twenty Fifteen: JSHint fixes.

  • Define global variables set by wp_localize_script().
  • Remove currently unused $ variable.
  • Use dot notation when appropriate.
  • Update Gruntfile.js to ignore the html5 shiv.

see #29799.

#3 @nacin
5 years ago

In 29895:

Set Twenty Fifteen as the new default theme. see #29799.

#4 @studionashvegas
5 years ago

#29947 references removing "Theme Customizer" in favor of "Customizer". Are we carrying this nomenclature through to the other themes (Twenty Fifteen included)?

If so, I'll own those changes.

EDIT: Figured I'd just do it and submit the patch. It's below.

Last edited 5 years ago by studionashvegas (previous) (diff)

@studionashvegas
5 years ago

29799 - Changed all references of "Theme Customizer" to "Customizer"

#5 @azaozz
5 years ago

In 29897:

Twenty Fifteen: clean up skip-link-focus-fix.js, see #29799

#6 @SergeyBiryukov
5 years ago

In 29900:

Twenty Fifteen: Update some more bundled theme references after [29895].

see #29799.

This ticket was mentioned in IRC in #wordpress-dev by johnbillion. View the logs.


5 years ago

#8 @azaozz
5 years ago

In 29909:

Twenty Fifteen: make font-size/line-height in editor-style.css the same as in style.css. Remove margins from the editor body, interferes with autoresize in some browsers and is overriden in the default styles. See #29799

#9 @azaozz
5 years ago

In 29910:

Twenty Fifteen: no rem in editor-style.css for now, see #29799

#10 follow-up: @iseulde
5 years ago

azaozz: [29909] broke blockquote and list styles (because they overflow the body). We need a bigger margin there, maybe 10%?

Also, see #29986.

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

#11 in reply to: ↑ 10 @azaozz
5 years ago

Replying to avryl:

Uh, didn't see #29986, maybe better to revert and handle it there?

[29909] sets the default font to 17px to better match the average window width, we can experiment with @media in editor-style.css to make the font-size scalable like on the front-end.

#12 @iseulde
5 years ago

Yeah, maybe. We also need to move over some responsive styles for blockquote etc. (they don't overflow for smaller screen sizes). The problem is that the main window width !== editor window width. :(

#13 @azaozz
5 years ago

The problem is that the main window width !== editor window width.

Yeah, this won't work with CSS only. Looking further, the editor styles need more work to keep the editor usable on small/narrow screens.

#14 follow-up: @azaozz
5 years ago

In 29911:

Twenty Fifteen, editor-style.css: revert the font-size back to 19px and margin back to 83px, merge the two body selectors (don't seem needed), remove redundant rtl rules and fix body.rtl selector. See #29799

#15 @iamtakashi
5 years ago

As requested, here is the out of sync Sass partials I used in development phase and I haven't touched for a while. Note that I didn't intended to distribute this and it's far from good.

https://cloudup.com/c8OjjriOYLG

#16 @jeherve
5 years ago

Twenty Fourteen displays a default menu (wp_page_menu) when the site owner didn't create any custom menu. I think Twenty Fifteen should do the same, for the primary menu.

I attached a patch.

Last edited 5 years ago by jeherve (previous) (diff)

@jeherve
5 years ago

Display a default menu when no custom menu was created

#17 follow-up: @iandstewart
5 years ago

@jeherve can you make a separate ticket for that?

#18 in reply to: ↑ 17 @jeherve
5 years ago

Replying to iandstewart:

@jeherve can you make a separate ticket for that?

Sure thing. #30022

#19 in reply to: ↑ 14 ; follow-up: @iamtakashi
5 years ago

Replying to azaozz:

In 29911:

Twenty Fifteen, editor-style.css: revert the font-size back to 19px and margin back to 83px, merge the two body selectors (don't seem needed), remove redundant rtl rules and fix body.rtl selector. See #29799

@azaozz,

max-width: 660px; doesn't work anymore since body.wp-autoresize wins though.

#20 in reply to: ↑ 19 ; follow-up: @azaozz
5 years ago

Replying to iamtakashi:

Right, that max-width should have been on body. We need to update the default styles in TinyMCE anyways, opened #30038 for that.

Last edited 5 years ago by azaozz (previous) (diff)

#21 in reply to: ↑ 20 @iamtakashi
5 years ago

Replying to azaozz:

Right, that max-width should have been on body. We need to update the default styles in TinyMCE anyways, opened #30038 for that.

OK, thanks!

This ticket was mentioned in IRC in #wordpress-dev by iandstewart. View the logs.


5 years ago

This ticket was mentioned in Slack in #core by iandstewart. View the logs.


5 years ago

#24 @iandstewart
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

We've introduced Twenty Fifteen! It's kind of awesome! Let's consider this task closed. :)

This ticket was mentioned in Slack in #core by iandstewart. View the logs.


5 years ago

Note: See TracTickets for help on using tickets.