WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29814 closed enhancement (duplicate)

Enhance Site Language settings support

Reported by: DeBAAT Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: I18N Keywords:
Focuses: administration Cc:
PR Number:

Description

Before WP 4.0, the language was defined by WPLANG in the wp-config.php file.

Since WP 4.0, the multi-language support has improved greatly from installation up to changing the settings on the General Settings screen.

However, when a site is installed from scratch using only the default US Engish language, the setting for Site Language is not available.

In this case, I consider it an enhancement when there is a note showing a link to more information on multi-language support.
The patch provided will accomplish this.

Any suggestions to improve the wording are appreciated.

Attachments (1)

29814.patch (1.9 KB) - added by DeBAAT 5 years ago.
Patch for file wp-admin/options-general.php - #29814

Download all attachments as: .zip

Change History (4)

@DeBAAT
5 years ago

Patch for file wp-admin/options-general.php - #29814

#1 @DeBAAT
5 years ago

  • Summary changed from Enahnce Site Language settings support to Enhance Site Language settings support

#2 follow-up: @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29395.

#3 in reply to: ↑ 2 @DeBAAT
5 years ago

Replying to ocean90:

Duplicate of #29395.

Thanks for this quick reply.

After analyzing the patch for #29395, it seems the Site Language setting can still be omitted when there is neither a language or translation available (for whatever reason).
Can you reconsider this enhancement, maybe to include it in the patch for #29395?

Note: See TracTickets for help on using tickets.