WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#29825 closed defect (bug) (fixed)

text or tags within of video shortcode causes editor preview to autoplay

Reported by: jwenerd Owned by: wonderboymusic
Milestone: 4.0.1 Priority: normal
Severity: normal Version: 3.6
Component: Media Keywords: fixed-major
Focuses: Cc:

Description

I've run into a regular occurrence where the videos previews in the visual post editor begin to autoplay. Each time it only occurs with when the track tag is added within the [video] shortcode.

This was done on latest truck in latest Chrome with no plugins.

Steps reproduce: Add a video into the visual post editor, then in the editor click the edit button appearing over the video preview, click add subtitles and upload or select a srt file then press "Add Subtitles", then click Update, switch the editor from into visual mode, (at this point the text looks like this http://cl.ly/image/3Q3M0l1p1V2H ), toggle back into visual editor and then the video begins to autoplay.

I noticed the lack of spacing between the kind and label attribute; I added the space and it still caused the preview to autoplay. Then I tried adding any text between the video shortcode and it still caused the video to autoplay. So it must be any text within the shortcode causing the text to autoplay when rendering the preview.

I've also run into this issue when adding updating subtitles to a video.

Change History (6)

#1 @helen
6 years ago

  • Component changed from Editor to Media
  • Focuses administration removed

wonderboymusic - can you take a look?

#2 @wonderboymusic
6 years ago

  • Milestone changed from Awaiting Review to 4.1

Confirmed.

#3 @wonderboymusic
6 years ago

  • Owner set to wonderboymusic
  • Resolution set to fixed
  • Status changed from new to closed

In 30185:

In wp_audio|video_shortcode(), make sure that autoplay and loop are booleans. Passing 'false' to them will force them to be active, which is bad.

Fixes #29825.

#4 @wonderboymusic
6 years ago

  • Milestone changed from 4.1 to 4.0.1
  • Resolution fixed deleted
  • Status changed from closed to reopened

If we do a 4.0.1, this would be good to fix.

#5 @johnbillion
6 years ago

  • Keywords fixed-major added
  • Version changed from trunk to 3.6

#6 @nacin
6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 30261:

In wp_audio|video_shortcode(), make sure that autoplay and loop are booleans. Passing 'false' to them will force them to be active, which is bad.

Merges [30185] to the 4.0 branch.

props wonderboymusic.
fixes #29825.

Note: See TracTickets for help on using tickets.