WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29854 closed enhancement (duplicate)

Add a hook for adding new menu settings

Reported by: stewarty Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Menus Keywords:
Focuses: Cc:
PR Number:

Description

I would like to add a setting to a menu (alongside the Theme locations or Auto add pages settings). A hook in nav-menu.php would allow for the addition of settings here.

The 'wp_update_nav_menu' hook already exists in wp-admin/includes/nav-menu.php for processing the incoming data (see how 'auto-add-pages' is processed.

Worth starting simply as a single hook and then filter by menu_id as well?

Change History (2)

#1 @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18584.

#2 @briandichiara
5 years ago

I think this might actually be a duplicate of #19464

Note: See TracTickets for help on using tickets.