WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#29864 closed defect (bug) (duplicate)

Brackets in instance Name of wp_editor() breaks Tinymce

Reported by: 3cees Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords:
Focuses: ui, javascript, administration Cc:

Description

If I a pass an array name for an editor ID , the editor gets only shown as "teeny".

As described in the functions refrence:

textarea_name
(string) (optional) The name assigned to the generated textarea and passed parameter when the form is submitted. (may include [] to pass data as array)
Default: $editor_id

It should work.

Here an example:

$editor_id = 'my_options[op_'.$pool["slug"].']';
wp_editor( $content, $editor_id, array( "media_buttons" => FALSE, "textarea_rows" => 10, "teeny" => FALSE ) );

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28079.

Note: See TracTickets for help on using tickets.