Make WordPress Core

Opened 16 years ago

Closed 15 years ago

#2987 closed defect (bug) (fixed)

+/- for bottom boxes on write page acts weird in FF

Reported by: viper007bond's profile Viper007Bond Owned by: andy's profile andy
Milestone: 2.0.6 Priority: high
Severity: minor Version: 2.0.4
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

Those bottom three boxes (trackbacks, excerpt, and custom fields), when they load collapsed, the +/- is weird and clicking the "+" doesn't actually expand it. It just changes it to a proper + and then clicking again finally expands it.

I'm using Firefox v2.0b1 and it was not a problem previously. I have an old install of 2.1-alpha1 and it doesn't do it there nor do I remember it doing this in 2.0.3. The sidebar ones work fine, it's just the bottom ones.

Attachments (1)

dbx-declass.diff (2.8 KB) - added by andy 15 years ago.

Download all attachments as: .zip

Change History (14)

#1 @Sewar
16 years ago

See #3001 also.

#2 @Nazgul
16 years ago

  • Keywords needs-patch added; bg|needs-patch removed

This is being caused by changeset 4001. To be more precise, by the addition of the -wrapper divs. If I remove those everyting works again, but the layout goes wonky.

#3 @matt
15 years ago

  • Priority changed from normal to high

#4 @matt
15 years ago

  • Owner changed from anonymous to andy

#5 @ryan
15 years ago

Just revert [4001]?

#6 @matt
15 years ago

Can we fix this without killing the curvy boxes?

#7 @andy
15 years ago

  • Status changed from new to assigned

@andy
15 years ago

#8 @andy
15 years ago

  • Keywords has-patch added; needs-patch removed

attached diff changes the class names of the wrappers so they are not matched by dbx when it looks for things to dbxize.

#9 @ryan
15 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4621]) Don't dbxize wrappers. Props andy. fixes #2987

#10 @Sewar
15 years ago

  • Keywords commit added
  • Milestone changed from 2.1 to 2.0.6
  • Resolution fixed deleted
  • Status changed from closed to reopened

This should be fixed in 2.0.x also.

#11 @markjaquith
15 years ago

Have confirmed this issue in 2.0.6 beta 1. Ryan, is this fix Kosher? I have no objection to slipping it into 2.0.6 if so. It's just a CSS rename...

#12 @ryan
15 years ago

I think it's safe for 2.0.6 Go ahead.

#13 @markjaquith
15 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4632]) Don't dbxize wrappers. Props andy. fixes #2987

Note: See TracTickets for help on using tickets.