WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#29871 closed defect (bug) (duplicate)

Select post category without select parent category

Reported by: pavelthq Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Posts, Post Types Keywords:
Focuses: Cc:
PR Number:

Description

Hello, i'm noticed that if I selected some child cat after saving post it moves this category to TOP level. this is missunderstading and this is not happening in quick edit.

Also a lot of tickets with Selecting Sub-category should select parent category, is this work's as expected? #16397

Attachments (1)

same_name.png (6.5 KB) - added by pavelthq 5 years ago.
two same category names with different parrents

Download all attachments as: .zip

Change History (7)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10982, #14723, #14916, #16475, #17135, #17317, #17835, #19880, #20160, #21544, #21127.

This is intentional, see #10982. A filter was introduced in #20054, allowing plugins to change that behaviour.

This plugin implements the change: https://wordpress.org/plugins/category-checklist-tree/.

@pavelthq
5 years ago

two same category names with different parrents

#2 @pavelthq
5 years ago

Okay, what if I have following structure:

Armani
---Shirts
Nike
---Shirts

I checked both this cat. and after page reload I have two same name cats, how to detect to disable armani shirts category for example?

#3 @pavelthq
5 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#4 @Bonesnap
5 years ago

I agree that this behaviour is both confusing and unintuitive. A project I have created recently for a client relies heavily on a parent/sub category structure. Several of the subcategories have the same name ("Other" for example), so it can be quite confusing. The client actually contacted us thinking there was a bug and they had ruined their categories on some of their posts. I'm glad I saw this ticket because I told them it was WordPress behaviour and I'd have to look into it. I was considering making a ticket but saw this one this morning.

The plugin that's linked says it's compatible up to 3.7.1... can anyone confirm that it works for 4.0?

It does strike me as odd that this was the consensus for expected behaviour regarding this, but I guess that's what the community wanted, though seeing the number of duplicate tickets is compelling.

#5 @SergeyBiryukov
5 years ago

I agree that it's confusing if you have multiple subcategories with the same name. It's a usability issue, as noted in comment:12:ticket:10982. However, that's how the current implementation works.

Use the plugin linked above if you need to keep the original hierarchy visible.

Replying to Bonesnap:

The plugin that's linked says it's compatible up to 3.7.1... can anyone confirm that it works for 4.0?

Yes, it does.

#6 @SergeyBiryukov
5 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #10982.

Note: See TracTickets for help on using tickets.