WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29878 closed enhancement (duplicate)

More Sample Options in wp-config-sample.php

Reported by: danielpataki Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Bootstrap/Load Keywords: has-patch
Focuses: docs Cc:

Description

I thought it would be a good idea to add some direction on some of the constants that may be defined in wp-config. While putting so many in the proposed patch may be overkill, perhaps adding things like the autosave interval and trash emptying constant would be helpful.

The only downside I can think of is overzealous users starting to edit things like WP_SITEURL, WP_ALLOW_REPAIR and such without proper reason.

Not sure this is the best way to go, just throwing it out there :)

Attachments (1)

wp-config-sample.diff (9.2 KB) - added by danielpataki 5 years ago.
Some added documentation for the wp-config-sample.php file

Download all attachments as: .zip

Change History (6)

@danielpataki
5 years ago

Some added documentation for the wp-config-sample.php file

#2 @kpdesign
5 years ago

  • Component changed from General to Bootstrap/Load
  • Keywords has-patch added

#3 follow-up: @ocean90
5 years ago

Please no. Some options are just too advanced and can break an install, if it's used wrong. I don't want to scare new users.

BTW: WPLANG is deprecated.

#4 in reply to: ↑ 3 @danielpataki
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28551.

Replying to ocean90:

Please no. Some options are just too advanced and can break an install, if it's used wrong. I don't want to scare new users.

BTW: WPLANG is deprecated.

I kind of agree with you, I just included all that to see everything in one place, it's easier to take away than to add, I din't find the related issue during a casual search.

I use some of these often but as I mentioned as well the risk factor is high with some of them. Plenty of good discussion on this in the other issue, I'll just shut up for now :)

#5 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.