WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#29905 closed defect (bug) (fixed)

Submenus don't scroll with Toolbar on mobile

Reported by: obenland Owned by: johnbillion
Milestone: 4.1 Priority: normal
Severity: normal Version:
Component: Toolbar Keywords: has-patch needs-testing make-flow
Focuses: Cc:

Description

Noticeable on small devices, if a submenu is active and the user scrolls, the toolbar disappears while the submenu stays.

First reported in: https://make.wordpress.org/flow/2014/07/07/the-guises-of-bar-nexus-5-4-0-alpha-20140706/

Attachments (3)

Screenshot_2014-07-07-07-41-58.png (101.5 KB) - added by obenland 6 years ago.
Screenshot_2014-07-09-20-41-48.png (216.7 KB) - added by obenland 6 years ago.
29905.patch (355 bytes) - added by iseulde 6 years ago.

Download all attachments as: .zip

Change History (8)

@iseulde
6 years ago

#1 @iseulde
6 years ago

  • Keywords has-patch needs-testing added

The problem is that the toolbar is not fixed for screens less than 600px, and for some reason we then fix the submenus? Doesn't make any sense.

#2 @iseulde
6 years ago

  • Milestone changed from Awaiting Review to 4.1

This ticket was mentioned in IRC in #wordpress-dev by avryl. View the logs.


6 years ago

#4 @iseulde
6 years ago

  • Keywords make-flow added; flow removed

#5 @johnbillion
6 years ago

  • Owner set to johnbillion
  • Resolution set to fixed
  • Status changed from new to closed

In 30706:

Don't fix the position of the admin toolbar submenus when the viewport is below 600px. This avoids them becoming detached from the admin toolbar when scrolling.

Fixes #29905
Props avryl

Note: See TracTickets for help on using tickets.