WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#29929 closed enhancement (duplicate)

make comments a custom post type

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Comments Keywords:
Focuses: Cc:

Description

I actually intended to request some better support for custom comment types but thinking about what I would actually like to get summed it up as "same as register_post_type", and then I realized that comments are just another type of content with the main difference is that it might be submitted by unauthorized users.

Given the sorry state of the ability to easily create new comment types, I think that going all the way to have it as post types is not that much harder. Sure there is the challenge of different tables, but having support for different tables per post type can make sense by itself for post types which are used to store information for the admin and can have many entries that are unrelated to frontend content, like sell transaction.

Change History (2)

#1 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12668.

#2 @SergeyBiryukov
4 years ago

  • Component changed from General to Comments
Note: See TracTickets for help on using tickets.