WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#29940 closed defect (bug) (duplicate)

ÅÄÖ Sorting

Reported by: 3dpc Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: administration Cc:
PR Number:

Description

I've noticed that ÅÄÖ (last three letters in the Swedish alphabet) aren't sorted corrected, e.g. in category lists which sorts the categories based on the first letter.

Here is an example:
http://i.imgur.com/iS8iALo.png

Same things happens if I output a list of the categories in a widget.

Attachments (1)

ScreenShot002.jpg (12.4 KB) - added by 3dpc 5 years ago.

Download all attachments as: .zip

Change History (3)

@3dpc
5 years ago

#1 @SergeyBiryukov
5 years ago

  • Component changed from General to I18N
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11740 and #15652. See also #18625.

#2 @knutsp
5 years ago

For Swedish sites I set the collation for certain, or all, columns to utf8_swedish_ci. The essential columns to change are terms.name, posts.post_title and users.display_name, using phpMyAdmin. For Norwegian and Danish sites I use utf8_danish_ci. When available, I use utf8mb4_* collations.

The easiest way is to set the default collation for the database before WordPress is installed.

Ideally WordPress should use proper collations according to selected WPLANG at install time. Do we need a new ticket for this?

Note: See TracTickets for help on using tickets.