WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#29960 closed enhancement (duplicate)

IF Twenty Fourteen does not exist, activate next found theme.

Reported by: Howdy_McGee Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Themes Keywords:
Focuses: administration Cc:

Description

There are many times whenever I install WordPress I will remove all the current theme and add in one of my own, so that there's only 1 custom theme upon installation. Currently how WordPress works is that it seems to look for Twenty Fourteen Theme which is fine and dandy by default but even if it doesn't exist it still loads it up.

My proposition is to check if the default theme exists, and if not move onto the next found theme and try to activate it.

Attachments (1)

themes.jpg (70.8 KB) - added by Howdy_McGee 7 years ago.
Missing Twenty Fourteen Theme

Download all attachments as: .zip

Change History (2)

@Howdy_McGee
7 years ago

Missing Twenty Fourteen Theme

#1 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28645.

Note: See TracTickets for help on using tickets.