WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#30048 closed defect (bug) (duplicate)

wp_options > option_name length

Reported by: akshay_raje Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Database Keywords:
Focuses: Cc:
PR Number:

Description

In the structure of wp_options, the option_name length is varchar(64).

It makes sense to change this to varchar(255) for the following reasons:

  • To make it inline with wp_postmeta and wp_usermeta schema
  • As the table is also used to store transient data (in absence of object cache plugins etc), 64 characters is often less for md5 hash based keys leading to cache misses.

Attachments (1)

schema.php (33.4 KB) - added by akshay_raje 5 years ago.

Download all attachments as: .zip

Change History (6)

@akshay_raje
5 years ago

#2 @akshay_raje
5 years ago

  • Keywords has-patch needs-testing added

#3 @nofearinc
5 years ago

  • Keywords has-patch needs-testing removed

Uploading the PHP file is not considered a legitimate patch, please consider creating a proper patch with SVN or Git following the Submitting a Patch guide from the handbook :)

Also, changing the schema could be quite dangerous for various reasons (locking, performance and data volume issues for large projects etc) so it should be inspected carefully.

#4 @jdgrimes
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #13310.

#5 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.