WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#30063 closed defect (bug) (invalid)

Twenty Fifteen: menu's show page content, screwing up layout

Reported by: tieptoep Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

When I switched to Twenty Fifteen, my menu got scambled and doesn't list all menu items because of it. It listed a whole lot of the text on the actual page, instead of what I expected the layout of a menu to look like. When this happens, it also doesn't show the secondary menu items.

I remade my normal menu from scratch and with this new version, the menu looked just fine.

The only difference I could see between the two versions is that the original uses title attributes with all menu items and the new version doesn't...

I have replicated the error by adding title attributes to the new version, but I can't seem to reproduce the error consistently.
Even so, the original menu keeps screwing up the layout of the menu and the new one doesn't.

Screenshots:
http://misc.tieptoep.nl/img/2015_menu_main.png The original menu, with screwed up layout.
http://misc.tieptoep.nl/img/2015_menu_test.png The copy, which looks fine.

Change History (6)

This ticket was mentioned in IRC in #wordpress-dev by tieptoep. View the logs.


5 years ago

#2 @TomHarrigan
5 years ago

I don't think this is a bug. Here's what I believe is happening:

With your problematic menu, go to Screen Options, check the "Description" box, as seen in the screenshot below. In your menu items, the large amount of text you're seeing on the front end should be visible in the "Description" box.

So, the extra text is being caused by the contents of the Description area in your original menu, where as the new menu did not have this field filled out.

http://i.imgur.com/m1sJw1Y.png

#3 @tieptoep
5 years ago

Ah... You're right!
I never saw that, so I never considered looking at it.

I'm sorry for filing it as a bug.
Should I close the ticket? Or better yet, set it as invalid?

#4 @tieptoep
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#5 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted

This ticket was mentioned in IRC in #wordpress-dev by johnbillion. View the logs.


5 years ago

Note: See TracTickets for help on using tickets.