WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 3 years ago

#3010 closed defect (bug) (fixed)

Rich Text Editor strips embed tags

Reported by: viperteq Owned by: westi
Milestone: 2.1 Priority: normal
Severity: normal Version: 2.0.4
Component: Administration Keywords:
Focuses: Cc:

Description

I'm not sure how this could be an issue since we're on version 2.0.4, but I have a major bug in Wordpress that I thought someone should know about.

I didn't really have a clue that it was a bug until I tried to display a flash-encoded video on my blog. For some reason, whenever I put the code in to embed the video it would seriously screw up my CSS. At first, i figured it was just the theme that I was using, but when I switched to the default WP theme, the CSS in that was screwed up as well.

I then thought that maybe it was me that was doing something wrong as I've never had a problem displaying content from Google or YouTube. Upon comparing my code to the code that youTube generates for embedding content, I surmised that that was not the problem as both were exactly identical.

So I started googling for information. I came across this thread which gave me some clues: http://wordpress.org/support/topic/81601?replies=2. Going back into the WP Dashboard I proceeded to disable the Rich Text editor as was suggested. Problem was that the Rich Text editor was ALREADY disabled. The reason that I thought that it wasn't was because I saw editing buttons above my post box.

http://7andacrescent.com/images/editor_Off.jpg
This pic shows what the post window looks like with the Rich Text editor turned off.

http://7andacrescent.com/images/editor_On.jpg
This pic shows what the post window looks like with the Rich Text editor turned on.

Basically no matter what you do, the editor is still present. I have tested this in the Mozilla Camino 1.0.2 browser, Flock 0.7 for Mac, Mozilla Firefox 1.5.0.6 for Mac, Mozilla Firefox 2.0 Beta for Mac, Internet Explorer 6, Mozilla Firefox 1.5.0.5 for Windows, Flock 0.7 for Windows and Opera 9 for Windows.

I was only able to successfully embed the video into my blog post in Apple's Safari browser (version 2.0.4) which completely strips out the editor even when the editor is enabled:

http://7andacrescent.com/images/editor_Safari.jpg

I think that this is a very major issue and like I said, I would've never noticed had I not had the problems that I had today trying to embed the video that I encoded in Flash.

If whoever is in charge of bugkilling needs anymore information, I will be happy to provide all that I can. I can be emailed at: viperteq.info {at} gmail {dot} com; Feel free to email me at any time. Thanks!

UPDATE: I created a thread over at the Wordpress.org forums: http://wordpress.org/support/topic/82441?replies=5 / I go into a lot more detail into what I've found there.

Change History (11)

comment:1 westi8 years ago

  • Keywords bg|reporter-feedback added
  • Owner changed from anonymous to westi
  • Priority changed from high to normal
  • Status changed from new to assigned
  • Version set to 2.0.4

Your images show correctly the two different views when the rich text editor is enabled/disabled.

If you look carefully you will see a different button bar when disabled - also the contents of the text field will be displayed as html rather than rich text.

Please provide an example of the code you are pasting in that doesn't work in the rich text editor otherwise we have no chance of tracking down any bug.

comment:2 harrisony8 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 foolswisdom8 years ago

Verified fixed using wordpress svn 4194

comment:4 foolswisdom8 years ago

  • Milestone set to 2.1

Confirmed bug in WordPress 2.0.4 .

comment:5 foolswisdom8 years ago

  • Summary changed from Rich Text Editor interferes with embedding multimedia files that use the object and embed tag. to Rich Text Editor strips embed tags

comment:6 intoxination8 years ago

The solution may be either including the Flash plugin that comes with TinyMCE, or using the code within that to properly handle the embed and object tags and adding that code to the default Wordpress TinyMCE plugin.

Another route would be to add an option that can be turned on and off in the writing options to allow embeds. This would simply activate/deactive the plugin in TinyMCE. This might be a better route for a future release.

comment:7 foolswisdom8 years ago

  • Keywords bg|reporter-feedback removed

Ryan explains "the newer version of tinyMCE that is in 2.1 is responsible for the fix."

Making it not a candidate for including in 2.0.5 .

comment:8 avibrazil7 years ago

I'm having the same problem with the WYSIWYG editor, and unlike viperteq, the problem isn't disapearing like magic.
It is clearly reproducible when trying to embed a YouTube video in a post. But I'm also having severe problems when pasting JavaScript code, <table>s (it simply eats my rows) and some CSS styles.

I don't know if this is the same problem, but disabling the WYSIWYG editor in WP administration, doesn't make it go away. I desabled "Users should use the visual rich editor by default" and "WordPress should correct invalidly nested XHTML automatically" but seems to have no effect on WP 2.0.4: I still get too much undesired XHTML intelligence, and the WYSIWYG editor.

See, this make complex posting simply impossible because if you select the plain HTML button to edit it, after editing the changes still goes inside the WYSIWYG widget. The changes appear there, but after saving the post, they disapear.

See also http://www.sutor.com/newsite/blog-open/?p=988 (but unlike me, he seems to be using a WP version that lets him disable the editor).

comment:9 avibrazil7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 foolswisdom7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Closing again as FIXED on trunk.

avilbrazil, thank you for thank you for participating in WP!

The original bug reported here seems to describes a very specific scenario fixed on WordPress trunk.

Some of the other problems you describe sounds like other tickets (not sure if opened or closed), but it is very important to isolate a problem and its symptoms.

"Also include information about your platform, such as operating system, web server softrware, PHP version, MySQL version etc."
http://codex.wordpress.org/Reporting_Bugs#Reporting_your_bug

I would also consider searching further here and at http://wordpress.org/support . Otherwise, possibly share your problems on the wp-testers mailing list (one problem per email thread ;-)

comment:11 propostaff3 years ago

spam.

Version 1, edited 3 years ago by nacin (previous) (next) (diff)
Note: See TracTickets for help on using tickets.