WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#3011 closed defect (bug) (duplicate)

Them-Editor theme file name listing problem

Reported by: Noct Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.4
Component: Template Keywords: theme-editor order alphabetical has-patch
Focuses: Cc:

Description

I'm not certain what causes it to happen but I believe it is within the WordPress software. I was transferred to a new server and basically upon reinstalling WordPress 2.0.4 I noticed when going into the Presentation link and then the Theme Editor link, that the Theme Editor 'WordPress Default theme files' listing was out of order.

Here is a picture describing what I am talking about:

http://www.noct.org/images/wp2.jpg

The one on the left is the correct version and this is how it was displayed prior to being moved to a new server. The one on the right is from a new host of mine and that is how it should be displayed.

Attachments (1)

3011.diff (448 bytes) - added by Nazgul 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 @Noct9 years ago

I just wanted to say that this not only happens with the k2 them installed. I can recreate it with the standard Kubrick if you would like me to. I just took the screen shot of the k2 because that is what I have installed right now. However, if need be, I'm more than willing to show you a screen shot of the actual Kubrick theme doing the same thing.

@Nazgul9 years ago

comment:2 @Nazgul9 years ago

  • Keywords has-patch added

It's caused by the PHP function 'dir'.

The following is noted in the manual for that function:
The order in which directory entries are returned by the read method is system-dependent.

The only solution I see would be to sort the list, which would give a fixed list on all machines. I've attached a patch that does that.

Only problem is that it's the filenames that are sorted, which leads to a non-alphabetical list, because file descriptions are shown on screen instead of filenames.

comment:3 @Nazgul9 years ago

Just noticed that this ticket is a partial duplicate of #2926.

comment:4 @foolswisdom9 years ago

  • Keywords theme-editor added; them editor removed
  • Priority changed from high to normal
  • Resolution set to duplicate
  • Status changed from new to closed

Marking duplicate of 2926.

Not sure why priority was set to high. Please be explicit if not choosing the defaults.

It seems better just to solve #2926 instead of this solution would results in a "non-alphabetical list".

Note: See TracTickets for help on using tickets.