WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#3015 closed defect (bug) (fixed)

wp_list_cats doesn't hide category with only a future post

Reported by: murky Owned by:
Milestone: 2.1 Priority: normal
Severity: normal Version: 2.0.4
Component: Administration Keywords:
Focuses: Cc:

Description

I have a futurepost in the category 'rugby' - it is the only post in this category.

There is no published post already posted in that category with a date before now.

On
http://www.murky.org/blg/category/sport/

wp_list_cats shows a link to the 'rugby' category, despite no posts being available. This makes for a broken link.

Here is the relevant code:

{{{ <?php

$query='sort_column=name&hide_empty=true&child_of=' . $cat;
wp_list_cats($query);

?>}}}

Change History (4)

comment:1 ryan8 years ago

Which version of WordPress? I think this is fixed in 2.1. Need to verify.

comment:2 murky8 years ago

I'm on 2.0.4

comment:3 Michael_8 years ago

  • Version set to 2.0.4

I can confirm this problem using WP 2.0.4 and list_cats(). A user has reported me the problem since I am using list_cats() in my plugin Category Tagging.

comment:4 ryan8 years ago

  • Milestone set to 2.1
  • Resolution set to fixed
  • Status changed from new to closed

This is fixed in 2.1. It won't be fixed in 2.0.x since the fix requires the new future posting infrastructure. We'll have to live with it until 2.1 arrives.

Note: See TracTickets for help on using tickets.