WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#30156 closed defect (bug) (fixed)

Twenty Fifteen Screenshot Image License Issue

Reported by: sakinshrestha Owned by: iandstewart
Milestone: 4.1 Priority: normal
Severity: normal Version: 4.1
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:
PR Number:

Description

As per the Theme Review Guideline in WordPress.org. Images in the screenshot has to be GPL compatible and it needs to add in the image source in readme.txt file.

Attachments (2)

30156.diff (604 bytes) - added by sakinshrestha 5 years ago.
Updating readme.txt file to add in the license details of image inside screenshot.png
30156.1.diff (611 bytes) - added by iamtakashi 5 years ago.
Remove the license details of image inside screenshot.png because it's Creative Commons Zero, which doesn't require attribution.

Download all attachments as: .zip

Change History (20)

#1 follow-up: @iamtakashi
5 years ago

The image is from unsplash.com and here is the license page: https://unsplash.com/license

@sakinshrestha Can you make a patch for the readme.txt?

#2 in reply to: ↑ 1 ; follow-up: @catchthemes
5 years ago

Replying to iamtakashi:

The image is from unsplash.com and here is the license page: https://unsplash.com/license

@sakinshrestha Can you make a patch for the readme.txt?

Thanks for the update. But as I remember the discussion with review team, that not all image in unsplash.com is GPL compatible. So, we need to check individual image for the verification. If you have image URL then it will be easy for me to check in. Thanks.

Last edited 5 years ago by catchthemes (previous) (diff)

#3 in reply to: ↑ 2 @catchthemes
5 years ago

Replying to catchthemes:

Replying to iamtakashi:

The image is from unsplash.com and here is the license page: https://unsplash.com/license

@sakinshrestha Can you make a patch for the readme.txt?

Thanks for the update. But as I remember the discussion with review team, that not all image in unsplash.com is GPL compatible. So, we need to check individual image for the verification. If you have image URL then it will be easy for me to check in. Thanks.

Ok I found the image and will do the patch. Thanks

#4 @iandstewart
5 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.1

#5 follow-up: @iandstewart
5 years ago

@catchthemes are you preparing a patch?

@sakinshrestha
5 years ago

Updating readme.txt file to add in the license details of image inside screenshot.png

#6 in reply to: ↑ 5 @sakinshrestha
5 years ago

Replying to iandstewart:

@catchthemes are you preparing a patch?

@iandstewart: Sorry I was in travel and couldn't add in the patch. I have just attached diff. I am not so sure on how do I submit the patch, as this is my first time submitting patch. Let me know if this is fine or do I need to add in other info.

#7 @iamtakashi
5 years ago

  • Keywords has-patch added; needs-patch removed

#8 @iandstewart
5 years ago

@sakinshrestha your first ticket, your first patch, and, soon, your first props. Nice work. :)

#9 @iandstewart
5 years ago

  • Owner set to iandstewart
  • Resolution set to fixed
  • Status changed from new to closed

In 30235:

Twenty Fifteen: adding licensing info for the image used in the screenshot.

Props sakinshrestha, fixes #30156.

#10 @sakinshrestha
5 years ago

Thanks a lot @iandstewart and @iamtakashi

#11 follow-up: @nacin
5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

as I remember the discussion with review team, that not all image in unsplash.com is GPL compatible

This doesn't ring true to me. unsplash.com is CC0, as in public domain + a fallback. Both are GPL compatible: https://www.gnu.org/licenses/license-list.html#CC0.

I suggest we revert [30235].

#12 in reply to: ↑ 11 ; follow-up: @sakinshrestha
5 years ago

Replying to nacin:

as I remember the discussion with review team, that not all image in unsplash.com is GPL compatible

This doesn't ring true to me. unsplash.com is CC0, as in public domain + a fallback. Both are GPL compatible: https://www.gnu.org/licenses/license-list.html#CC0.

I suggest we revert [30235].

  • As per the Theme Review Guideline, all images used in Theme needs to to be GPL Compatible and needs proper attribution. So, there should be image URL and license details. Even that is from unsplash.com or any other GPL compatible domain.
  • Also note that not all image in unsplash.com is GPL compatible. Read this discussion https://make.wordpress.org/themes/2014/06/05/gpl-compatible-images/
Version 0, edited 5 years ago by sakinshrestha (next)

#13 in reply to: ↑ 12 ; follow-up: @iamtakashi
5 years ago

Replying to sakinshrestha:

Is this true? Doesn't Luke confirmed every image in unsplash.com has been reviewed CC0 which is GPL compatible?

#14 in reply to: ↑ 13 @sakinshrestha
5 years ago

Replying to iamtakashi:

Replying to sakinshrestha:

Is this true? Doesn't Luke confirmed every image in unsplash.com has been reviewed CC0 which is GPL compatible?

Last edited 5 years ago by sakinshrestha (previous) (diff)

#15 @nacin
5 years ago

Something does not require attribution for it to be compatible with the GPL. If something is Public Domain or Creative Commons Zero, there is no required attribution. It remains compatible with the GPL. In this case, it's just a matter of whether it is compatible with the theme review process, not the GPL.

I don't really care what needs to happen on the theme review side to ease things for the overall review process, but in this case, I'm still for reverting [30235]. Default themes do not need this cruft.

And generally speaking, the theme review process shouldn't require that this actually appears in the readme. Leaving a comment on the theme review Trac ticket should be sufficient for verification purposes, assuming attribution is not required.

That image would not be on unsplash.com if it were not Creative Commons Zero. It seems to me like that image was granted CC0 by Rafael Fabricio so it could appear on unsplash.com. You can also get it from his page on 500px under a different license. I presume Unsplash is a good marketing opportunity, as then you could also get other images from 500px as well.

As Rarst wrote in https://make.wordpress.org/themes/2014/06/05/gpl-compatible-images/:

Note that copyright holder (original author) can release the work under different licenses. There is nothing preventing author from submitting photo to unsplash under CC0 and having it hosted under different license elsewhere.

This is 100% correct. And, the co-founder of Unsplash verified all of this and more.

@iamtakashi
5 years ago

Remove the license details of image inside screenshot.png because it's Creative Commons Zero, which doesn't require attribution.

This ticket was mentioned in Slack in #core-themes by lancewillett. View the logs.


5 years ago

#17 @lancewillett
5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 30867:

Twenty Fifteen: remove license details for the image shown in the theme screenshot file as it is Creative Commons Zero, which doesn't require attribution.

Props iamtakashi, fixes #30156.

#18 @johnbillion
5 years ago

In 30877:

Twenty Fifteen: remove license details for the image shown in the theme screenshot file as it is Creative Commons Zero, which doesn't require attribution.

Merges [30867] to the 4.1 branch.

Props iamtakashi
See #30156

Note: See TracTickets for help on using tickets.