WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#3023 closed defect (bug) (fixed)

Privacy option doesn't get set (or something)

Reported by: Viper007Bond Owned by: markjaquith
Milestone: 2.1 Priority: normal
Severity: normal Version: 2.1
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

During install, it asks you if you would like to have your blog show up on Google and such or whatever. I left the box checked.

Now on Options -> Privacy, neither radio button is selected. :/

Attachments (1)

blog_public_fix.diff (820 bytes) - added by markjaquith 9 years ago.
Fix for /trunk/

Download all attachments as: .zip

Change History (8)

comment:2 @Viper007Bond9 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I had already picked a radio and saved, but I just did two fresh installs and was unable to reproduce it on my local machine. Oh well.

comment:3 @markjaquith9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I just did a Trunk install and was able to reproduce.

comment:4 @markjaquith9 years ago

  • Keywords needs-patch assigned added
  • Owner changed from anonymous to markjaquith
  • Status changed from reopened to new

Option is blank in the options table... isn't being set properly. I'm working on a patch now.

@markjaquith9 years ago

Fix for /trunk/

comment:5 @markjaquith9 years ago

  • Keywords has-patch commit added; needs-patch assigned removed
  • Status changed from new to assigned

Okay, there's nothing wrong with the install/upgrade code... this bug is only triggered when you submit options-general.php

I guess the blog_public option used to be there, so it was in the list of options to update, and gets blanked when you submit that options page. I thought I was going crazy looking at the install/upgrade code... "this should be working!"

comment:6 @Viper007Bond9 years ago

Ah, that makes sense. Yeah, I had been playing with other options on my client's install before going to that page. I remember that now. :)

comment:7 @ryan9 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4115]) Blog public fix from Mark J. fixes #3023

Note: See TracTickets for help on using tickets.