WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#30241 closed defect (bug) (duplicate)

302 redirect loops when switching to https - because of do_action( 'setup_theme' );

Reported by: guaka Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: administration Cc:

Description

I'm getting a 302 redirect loop when trying /wp-admin/customize.php
I pinpointed the problem to a call to do_action( 'setup_theme' );

Note it's still happening after disabling all plugins and switching to different themes (including 2014).

Change History (3)

#1 @guaka
5 years ago

Found out that it's related to https.

If I revert to http there is no redirect loop.

I'm using https over cloudflare, so the server is actually only serving http.

#2 @guaka
5 years ago

  • Summary changed from 302 redirect loop because of do_action( 'setup_theme' ); to 302 redirect loops when switching to https - because of do_action( 'setup_theme' );

Apparently it's not just me. The wordpress-https extension doesn't fix it.
See also http://wordpress.stackexchange.com/questions/163638/wordpress-https-redirect-loop

#3 @jeremyfelt
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.0 deleted

Hi @guaka, thanks for the report. It looks like this is a duplicate of #29708, which is fixed in trunk and intended to ship in 4.0.1 as well.

Note: See TracTickets for help on using tickets.