WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#30259 closed enhancement (duplicate)

Add extra hooks to wp-comments-post.php before call wp_die()

Reported by: Bondars Aleksandr Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Comments Keywords: has-patch
Focuses: template Cc:

Description

Hi all. It would be cool if you added to wp-comments-post.php acitons before wp_die(). For example:
before

wp_die( __('Sorry, you must be logged in to post a comment.') );

add

do_action('login_comment_error')

This will greatly help in creating AJAX processing comments and other.

Attachments (1)

wp-comments-post.php.patch (1.3 KB) - added by Bondars Aleksandr 6 years ago.
Patch wp-comments-post.php

Download all attachments as: .zip

Change History (4)

@Bondars Aleksandr
6 years ago

Patch wp-comments-post.php

#1 @Bondars Aleksandr
6 years ago

  • Keywords has-patch added

#2 @rachelbaker
6 years ago

  • Milestone changed from Awaiting Review to Future Release

Bumping to "Future Release" for consideration as an enhancement.

#3 @SergeyBiryukov
6 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16979 and #18630.

Note: See TracTickets for help on using tickets.