WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#30276 closed enhancement (duplicate)

Media library, admin-ajax.php, not all images are visible

Reported by: Stagger Lee Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

I wont tag this as "defect(bug)", maybe all that is needed is small enhancement, make code slightly more robust, some few more checks.

All is explained on this support forum topic:
https://wordpress.org/support/topic/media-library-in-post-wont-load-images-calls-admin-ajaxphp-constantly/page/2?replies=41#post-6204216

Many people have this problem.
My problem was fixed by plugin Media Library Assistant, but it should not be needed. Core code needs to handle this well without plugins.

Anyway read all on this topic, i believe most people have same problem. Not all, but most of them.

Please read my comments on this topic about dropdown select and what works perfectly and what doesnt work. Can maybe give you some directions to what is making problems.

I repet one more time, i dont believe it is bug. Just that code doesnt take consideration for all real life situations. But again, if this plugin fix it then core code should handle it well too.

Change History (10)

#3 @SergeyBiryukov
6 years ago

  • Description modified (diff)

Replacing the link per comment:1.

#4 @Stagger Lee
6 years ago

Can soomeone give some reasonable explanation. This one is driving me crazy.

Why "All media items" doesnt list all images, and stuck on maybe 10% images?

And why in same modal window "Unattached" list all images ?
(almost all, unattached anyway, but not so important here)

Is it not crazy ?

Version 0, edited 6 years ago by Stagger Lee (next)

#5 @SergeyBiryukov
6 years ago

Might be related to #31116.

#6 @Stagger Lee
6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Yes, yes, yes...it is OK now. I will put trac url on forum topic. Please make this piece of code more nice on second trac. I had it difficult to find in media-models.min.js.

#7 @SergeyBiryukov
6 years ago

  • Keywords close reporter-feedback removed
  • Resolution changed from worksforme to duplicate

Duplicate of #31116.

#8 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted

#9 @Stagger Lee
6 years ago

Can we get some clear info if it is fixed in some version ? v4.1, v4.2 ?

As it is now I have no clue if I have to do it manually or not. Or maybe I cannot decode trac system here.

(sorry, it sholud go on the other trac)

Last edited 6 years ago by Stagger Lee (previous) (diff)

#10 @DrewAPicture
6 years ago

Hi @stagger-lee,

This ticket was closed as a duplicate of #31116, which has been fixed and will ship with 4.2.

Note: See TracTickets for help on using tickets.