WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#30435 closed task (blessed) (fixed)

4.1 About screen

Reported by: johnbillion Owned by: nacin
Milestone: 4.1 Priority: normal
Severity: normal Version: 4.1
Component: Help/About Keywords: dev-feedback i18n-change
Focuses: ui Cc:

Description

Holding ticket for notes on what we want to highlight on the About screen for 4.1. Comment at will.

Attachments (5)

30435.patch (7.1 KB) - added by ramiy 5 years ago.
translation ready text
30435.diff (18.0 KB) - added by ryelle 5 years ago.
30435.1.diff (20.2 KB) - added by ryelle 5 years ago.
41_about_firefox.png (1.3 MB) - added by DrewAPicture 5 years ago.
30435.2.diff (295 bytes) - added by melchoyce 5 years ago.

Download all attachments as: .zip

Change History (48)

#1 @kpdesign
5 years ago

Users:

  • New default theme: Twenty Fifteen
  • Focus: new distraction-free writing mode for the editor
  • Automatically install new language packs from the General Settings page
  • Session management: ability to log out of all other open sessions

Developers:

  • External Libraries have been updated (TinyMCE, MediaElements, getID3, Iris)
  • Better way to handle theme Title Tag
  • Customizer API improvements

#2 follow-up: @afercia
5 years ago

I'd propose to don't auto play videos :) in 4.0 there are two videos ("focus" and "embed") set to autoplay => true that's a terrible experience for users with old, slow machines without a dedicated GPU and bad for accessibility. Please :)

#3 in reply to: ↑ 2 ; follow-up: @helen
5 years ago

Replying to afercia:

I'd propose to don't auto play videos :) in 4.0 there are two videos ("focus" and "embed") set to autoplay => true that's a terrible experience for users with old, slow machines without a dedicated GPU and bad for accessibility. Please :)

They were autoplay because they were essentially animated GIFs, just with a smaller file size. I imagine large animated GIFs do the same thing to an older machine? Don't anticipate any in this release, in any case.

#4 in reply to: ↑ 3 @afercia
5 years ago

Replying to helen:

They were autoplay because they were essentially animated GIFs,

Maybe in 3.9 they were GIFs, not sure. In 4.0 I see this:

echo wp_video_shortcode( array(
	'mp4'      => '//s.w.org/images/core/4.0/embed.mp4',
	'ogv'      => '//s.w.org/images/core/4.0/embed.ogv',
	'webm'      => '//s.w.org/images/core/4.0/embed.webm',
	'loop'     => true,
	'autoplay' => true,
	'width'    => 500,
	'height'   => 352
) );

then rendered by mejs. In Chrome I get the .mp4, in Firefox the .webm.

#5 @dd32
5 years ago

Maybe in 3.9 they were GIFs, not sure.

essentially gifs - they were video files being used as gifs (because, well, most videos are smaller and more efficient than gifs), I think the benefits of audio-less autoplay videos on the about screen outweighed the potential performance issue for the minority of users.
As said however, it's unlikely we'll have one this time around, although Focus might be able to benefit from a short one.

This ticket was mentioned in Slack in #core by johnbillion. View the logs.


5 years ago

This ticket was mentioned in Slack in #core by johnbillion. View the logs.


5 years ago

This ticket was mentioned in Slack in #core-themes by iandstewart. View the logs.


5 years ago

#9 @nacin
5 years ago

In 30821:

About page, text only (not released for translation), first pass.

Design and finalized text to follow. This is just for the RC crowd.

props johnbillion, helen, markjaquith, nacin.
see #30435.

#10 @nacin
5 years ago

In 30822:

About page text, first pass.

Merges [30821] to the 4.1 branch.

props johnbillion, helen, markjaquith, nacin.
see #30435.

#11 @SergeyBiryukov
5 years ago

Log out everywhere

There’s a new tool on your profile that logs you out everywhere, for those times you forget to log off a shared computer.

I went to my profile after reading this, but didn't see the "Log Out of All Other Sessions" button. Looks like it's only displayed if you have more than one active session. Might be confusing.

#12 @iseulde
5 years ago

I had the exact same thought.

@ramiy
5 years ago

translation ready text

#13 follow-up: @ramiy
5 years ago

Guys, you need to make the text translation ready.

We cant see the text in glotpress.

See the attached patch.

This ticket was mentioned in Slack in #core by melchoyce. View the logs.


5 years ago

#15 in reply to: ↑ 13 @ocean90
5 years ago

Replying to ramiy:

Guys, you need to make the text translation ready.

We cant see the text in glotpress.

That's by design. The strings aren't final yet.

#16 @celloexpressions
5 years ago

The current thing that's listed for the Customizer is just one of several side effects of the bigger changes to the API this cycle. I'd recommend something like the following to summarize: "Expanded JavaScript APIs in the Customizer enable support for dynamic and contextual controls, sections, and panels, and a new media experience."

But, to be completely honest, the new media (or even just background image) controls are a more significant feature than something like Vine embeds... if we need more new stuff to showcase, the Customizer definitely has stuff. I could maybe see a section in the user-facing part saying something like "We've consolidated the Headers and Backgrounds admin screens into the Customizer.", which could also have a (potentially deep-linked) Customize button with .load-customize to add an interactive element (and they'll go back to the about page when they close the Customizer if you use that class).

#17 @nacin
5 years ago

In 30840:

About page updates.

  • Live-update the number of active translations.
  • Finalize most strings.
  • Lazily remove links to admin-only screens based on cap checks.

see #30435.

#18 @nacin
5 years ago

In 30841:

Finalize more about page strings. see #30435.

@ryelle
5 years ago

#19 @ryelle
5 years ago

30435.diff has the new styles for the about page, using cloudup for temporary image hosting. I've embedded SVGs for the icons of "The Finer Points", but still need to add a fallback. Also not here: the dfw animation, since I don't have the gifs for it yet.

Additionally, I restructured about.css and renamed some classes (under-the-hood -> feature-list, about-overview -> featured-image, removed about-headline-callout) since some of them are reused a few times on the page and didn't make much sense. I've confirmed that this didn't change Credits and Freedoms, and the point-release classes are also still in place. If there's a reason I shouldn't do this, I can make another patch without the restructure (this has just been bothering me since I started working on the about page).

@ryelle
5 years ago

#20 @ryelle
5 years ago

30435.1.diff adds the distraction free writing animation.

#21 @nacin
5 years ago

In 30857:

About page design for 4.1.

props melchoyce and ryelle, who again outdid themselves.
see #30435.

#22 @nacin
5 years ago

In 30858:

About page updates.

  • Live-update the number of active translations.
  • Finalize most strings.
  • Lazily remove links to admin-only screens based on cap checks.

Merges [30840] and [30841] to the 4.1 branch.

see #30435.

#23 @nacin
5 years ago

In 30859:

About page design for 4.1.

Merges [30857] to the 4.1 branch.

props melchoyce and ryelle, who again outdid themselves.
see #30435.

#24 @DrewAPicture
5 years ago

Looks like the layout in Firefox is a little fubar. See 41_about_firefox.png

#25 @iseulde
5 years ago

I had the same problem in Chrome, but it was solved after a refresh.

#26 follow-up: @markjaquith
5 years ago

The DFW transitions aren't working in Safari.

#27 @ocean90
5 years ago

In 30884:

Autoprefixer for [30857].

see #30435.

#28 in reply to: ↑ 26 @ocean90
5 years ago

Replying to markjaquith:

The DFW transitions aren't working in Safari.

[30884] fixed it for me, tested in Version 8.0.2 (10600.2.5).

#29 @nacin
5 years ago

In 30887:

Finalize two more about page strings. see #30435.

#30 @nacin
5 years ago

In 30889:

Update/add plugin recommendation strings.

Update [30887], add a translation function to the Vine string.

fixes #30337. see #30435.

#31 @nacin
5 years ago

I've embedded SVGs for the icons of "The Finer Points", but still need to add a fallback.

Do we care? I'm not sure we do. If the fallback is "nothing appears," I'm totally cool with that.

using cloudup for temporary image hosting

Moving this to wordpress.org is the only thing I can think of that still needs to be done here. Oh, and that customizer string is still unfrozen.

#32 @johnbillion
5 years ago

In 30894:

Finalize two more about page strings.

Merges [30887] to the 4.1 branch.

See #30435

#34 @johnbillion
5 years ago

In 30902:

Autoprefixer for [30857].

Merges [30884] to the 4.1 branch.

See #30435.

#35 @johnbillion
5 years ago

In 30903:

Move a <code> tag out of a localised string on the About page.

Props pavelevap
See #30435

#36 @johnbillion
5 years ago

In 30904:

Move a <code> tag out of a localised string on the About page.

Merges [30903] to the 4.1 branch.

Props pavelevap
See #30435

#37 follow-up: @johnbillion
5 years ago

  • Keywords dev-feedback i18n-change added

The one remaining string to be localised is the customizer string:

"The customizer now supports conditionally showing panels and sections based on the page being previewed."

Are we happy with that?

#38 in reply to: ↑ 37 @celloexpressions
5 years ago

Replying to johnbillion:

The one remaining string to be localised is the customizer string:

"The customizer now supports conditionally showing panels and sections based on the page being previewed."

Are we happy with that?

I still like "Expanded JavaScript APIs in the Customizer enable support for dynamic and contextual controls, sections, and panels, and a new media experience.", and it actually fits pretty well length-wise with the other strings there. Mentions both the main Customizer focus this release, some API stuff it enabled, and the core example of using it (the media controls). Also subtly hints at our future plans, which rely heavily on the new API (menus, theme-switching, etc.).

@melchoyce
5 years ago

#39 @melchoyce
5 years ago

30435.2.diff makes a super minor style tweak to kill of the orphan in the DFW section on desktop.

#40 @johnbillion
5 years ago

In 30921:

Make the DFW paragraph on the About page narrower to mitigate an orphan in Firefox.

See #30435
Props melchoyce

#41 @johnbillion
5 years ago

In 30922:

Make the DFW paragraph on the About page narrower to mitigate an orphan in Firefox.

Merges [30921] to the 4.1 branch.

See #30435
Props melchoyce

#42 @nacin
5 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 30929:

Last about page string. props celloexpressions. fixes #30435.

#43 @nacin
5 years ago

In 30930:

Last about page string. Merges [30929] to the 4.1 branch.

props celloexpressions.
fixes #30435.

Note: See TracTickets for help on using tickets.