WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#30482 closed defect (bug) (wontfix)

Remove PHP4 compatibility wrapper function since WordPress requires PHP5 from version 3.2+

Reported by: jazzs3quence Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Widgets Keywords: close
Focuses: Cc:
PR Number:

Description

WordPress no longer supports PHP4 and hasn't for a long while. These PHP4 compatibility functions are no longer needed.

Attachments (1)

30482.diff (620 bytes) - added by jazzs3quence 5 years ago.

Download all attachments as: .zip

Change History (4)

@jazzs3quence
5 years ago

#1 @blobaugh
5 years ago

  • Keywords has-patch needs-testing added

#2 @ocean90
5 years ago

  • Focuses docs removed
  • Keywords close added; has-patch needs-testing removed

It's needed for backwards compatibility, see #20801 and ticket:16768:9.

#3 @johnbillion
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for the ticket jazzs3quence but these PHP 4 style constructors are needed for compatibility reasons.

Note: See TracTickets for help on using tickets.