WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#30555 closed defect (bug) (duplicate)

wp-db.php warns of mysql_fetch_object() on a boolean or or on a non-object

Reported by: petermantos Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Database Keywords:
Focuses: multisite Cc:
PR Number:

Description

wp-db.php has a bug around line 1616 (most recent version as of 11/30/2014)

They error reported is:
Debug Warning: ...\wp-includes\wp-db.php line 1622
mysql_fetch_object(): supplied argument is not a valid MySQL result resource

A similar comes up under different circumstances that basically states that the result is a boolean, not an object.

The solution is to make a test as to whether or not the result is an object using is_object as follows:

$num_rows = 0;
if ( is_object($this->result ) ) {
if ( $this->use_mysqli ) {

while ( $row = @mysqli_fetch_object( $this->result ) ) {

$this->last_result[$num_rows] = $row;
$num_rows++;

}

} else {

while ( $row = @mysql_fetch_object( $this->result ) ) {

$this->last_result[$num_rows] = $row;
$num_rows++;

}

}
}

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27982.

Note: See TracTickets for help on using tickets.