WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#30573 closed defect (bug) (worksforme)

Customize Theme in Admin Broken

Reported by: Son_of_the_Raven Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0.1
Component: Customize Keywords: reporter-feedback
Focuses: Cc:

Description

I downloaded WordPress 4.1-beta2-30693 and when I go to Appearance > Customize in the admin section I get a 403 Forbidden Error. If I choose Customize under Appearance > Themes, all works as expected.

Change History (11)

#1 @MikeHansenMe
3 years ago

I am unable to reproduce this. Are you using any plugins/themes besides the default?

#2 @Son_of_the_Raven
3 years ago

It is a clean install. The only plugin active is the WordPress Beta Plugin.

I looked at my raw logs and I found this line as a 500 error:

108.67.81.64 - - [02/Dec/2014:10:43:29 -0500] "GET /dev/wp-admin/customize.php?return=%2Fdev%2Fwp-admin%2Findex.php HTTP/1.1" 500 - "http://www.domain.com/dev/wp-admin/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36"

FWIW, it looks like it is trying to edit the admin page instead of the theme.

#3 @ocean90
3 years ago

  • Component changed from General to Customize
  • Version changed from 4.0.1 to trunk

Does it work in WordPress 4.0.1 on the same server? Can you please check your PHP error log? What happens when you access the Customizer via http://domain.com//dev/wp-admin/customize.php?return=%2Fdev%2Fwp-admin%2Findex.php directly? What happens when you click on the Appearance > Header/Background links?

#4 @Son_of_the_Raven
3 years ago

I will check it as soon as possible. I am working on another project that needs my full attention at the moment. I will set up a test tonight.

#5 @johnbillion
3 years ago

  • Keywords reporter-feedback added

#6 @Son_of_the_Raven
3 years ago

Did a separate install of 4.0.1 and got the same error. I checked another site I've worked on too. I got the same error there.

This ticket was mentioned in Slack in #core by helen. View the logs.


3 years ago

#8 @helen
3 years ago

  • Version changed from trunk to 4.0.1

#9 @celloexpressions
3 years ago

Most likely the issue here is something server-related that's avoided when the Customizer is loaded in an iframe. The other, bigger difference (besides the return param) between those two ways of loading the Customizer is that the customize-loader script is used to load the Customizer in an iframe over the admin on the themes screen (and the dashboard).

#10 @afercia
2 years ago

  • Keywords close added

Was anyone able to reproduce this issue? If not, I'd kindly suggest to close this ticket.

#11 @SergeyBiryukov
2 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.