WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#30637 closed defect (bug) (duplicate)

Tapping a toolbar item to close it, opens the link instead

Reported by: pento Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Toolbar Keywords: has-patch
Focuses: ui, javascript Cc:

Description

To reproduce:

  • Login on a mobile device
  • Tap "+" (Add New) to open the Add New menu
  • Tap the "+" to close the menu again

Instead of closing the menu, the default menu item is opened. Given that the only other way to close the menu is to tap below it, this makes it impossible to close long menus.

Attachments (1)

30637.diff (970 bytes) - added by pento 6 years ago.

Download all attachments as: .zip

Change History (6)

@pento
6 years ago

#1 @pento
6 years ago

  • Keywords has-patch added

#2 @miqrogroove
6 years ago

Could you attach a screenshot? On tablets we generally just tap away, so if you have a menu covering the whole screen I think a picture would help.

#3 @iseulde
6 years ago

Duplicate? #29906

#4 @azaozz
6 years ago

This is tricky :) Often the toolbar items themselves are links. Currently we open the submenu on the first tap, then follow the link on the second. If we close the submenu on the second tap, there will be no way to access these links.

#5 @pento
6 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29906.

Nice catch, @avryl. :-)

Note: See TracTickets for help on using tickets.