WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#3064 closed defect (bug) (duplicate)

Ampersand Patch

Reported by: murky Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

I've had some difficulty with & in rss feeds (syndicated, so I had to automatically deal with them).

I've worked it through, it involved editing some films and I'd like to submit a patch for approval....

Details are here.

http://wordpress.org/support/topic/84477

I'll keep hunting for details of how to submit a patch for a little while.

Attachments (1)

patch.txt (1.5 KB) - added by murky 9 years ago.
I had a problem with ampersands in urls of syndicated posts. This patch hopes to clean them up.

Download all attachments as: .zip

Change History (9)

comment:1 @murky9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Think I've got it... subversion, make the changes to copy in repository, update.

Patches to be submitted soon.

comment:2 @murky9 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

svn commit did not work (my username/password not accepted... reasonable as you don't need anyone able to commit changes!)

I've attached my patch here (though I couldn't find function comments_link in the current trunk, time is short, so I've only patched two of the three)

Hope I've done this right!

comment:3 @markjaquith9 years ago

SVN Commit access is closed... two people commit patches: Matt and Ryan.

The process is as follows:

Don't mark tickets with patches as resolved... add the keyword "has-patch" When Matt/Ryan commits the patch, THEN they'll mark it as resolved. We don't consider the issue resolved until the core code has been patched.

So, why don't you create a new ticket for this issue and upload your patch. thanks for contributing!

@murky9 years ago

I had a problem with ampersands in urls of syndicated posts. This patch hopes to clean them up.

comment:4 @murky9 years ago

  • Summary changed from Submit a patch to Ampersand Patch
  • Type changed from enhancement to defect

Now done all three patches. Patch updated

comment:5 @murky9 years ago

  • Keywords has-patch added

comment:6 @murky9 years ago

Just seen the note from mark.

Opening new ticket as requested.

comment:7 @foolswisdom9 years ago

I don't think Mark was telling you to open a new ticket. I have closed #3065 as a duplicate of this ticket.

comment:8 @foolswisdom9 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

LOL, it seems he was. I misread it. I will close this as the duplicate then of #3065.

Note: See TracTickets for help on using tickets.